summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:25:30 +0200
committerDan Johansen2019-09-16 15:25:30 +0200
commit3feb6a935041ac5f46330b799e7e44afedcca0f6 (patch)
tree3cb8cf81765b3128c631beb930d3cf192a7953f7
downloadaur-3feb6a935041ac5f46330b799e7e44afedcca0f6.tar.gz
initial commit, version 2.7
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bb22f446d42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = coreuniverse
+ pkgdesc = Shows information about apps from the CoreApps family.
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/coreuniverse
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = GPL3
+ depends = qt5-base
+ depends = libcprime
+ source = https://gitlab.com/cubocore/coreuniverse/-/archive/v2.7.0/coreuniverse-v2.7.0.tar.gz
+ md5sums = 05c75e1609ff95e46ef3120dc6c023cb
+
+pkgname = coreuniverse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15489cde6d54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=coreuniverse
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Shows information about apps from the CoreApps family."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'libcprime')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('05c75e1609ff95e46ef3120dc6c023cb')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}