summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32021-03-08 16:09:27 +0100
committerdr460nf1r32021-03-08 16:09:27 +0100
commit6eb566a04496e4cf8f0d219d8569528574c0bafa (patch)
tree7db1ab4030dc750da4384543fcc5079fed35a600
downloadaur-6eb566a04496e4cf8f0d219d8569528574c0bafa.tar.gz
Initial upload
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD71
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1fceded2163
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = coreutils-hybrid
+ pkgdesc = GNU Coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished
+ pkgver = 8.32_0.0.3
+ pkgrel = 1
+ url = https://www.gnu.org/software/coreutils/
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ makedepends = python-sphinx
+ depends = glibc
+ depends = acl
+ depends = attr
+ depends = gmp
+ depends = libcap
+ depends = openssl
+ provides = coreutils
+ conflicts = coreutils
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz.sig
+ source = uutils-coreutils-0.0.3.tar.gz::https://github.com/uutils/coreutils/archive/0.0.3.tar.gz
+ validpgpkeys = 6C37DC12121A5006BC1DB804DF6FD971306037D9
+ sha256sums = 4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = coreutils-hybrid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b32c7bca5734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: dr460nf1r3 <dr460nf1r3@garudalinux.org>
+# Contributor: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=coreutils-hybrid
+_pkgname=coreutils
+__pkgname=uutils-coreutils
+pkgver=8.32_0.0.3
+_pkgver=8.32
+__pkgver=0.0.3
+pkgrel=1
+pkgdesc='GNU Coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished'
+arch=('x86_64')
+license=('GPL3')
+url='https://www.gnu.org/software/coreutils/'
+_url='https://github.com/uutils/coreutils'
+depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
+conflicts=('coreutils')
+provides=('coreutils')
+makedepends=('rust' 'cargo' 'python-sphinx')
+source=("https://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$_pkgver.tar.xz"{,.sig}
+ "$__pkgname-$__pkgver.tar.gz::$_url/archive/$__pkgver.tar.gz")
+validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
+sha256sums=('4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd $_pkgname-$_pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ # Build GNU coreutils without the stable uutils programs counterparts
+ cd $_pkgname-$_pkgver
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-openssl \
+ --enable-no-install-program="groups,hostname,kill,uptime,arch,base32,base64,basename,cat,chgrp,chmod,chown,chroot,cksum,comm,csplit,cut,dircolors,dirname,du,echo,env,expand,factor,false,fmt,fold,groups,hashsum,head,hostid,hostname,id,kill,link,ln,logname,mkdir,mkfifo,mknod,mktemp,mv,nice,nl,nohup,nproc,paste,pathk,pinky,printenv,ptx,pwd,readlink,realpath,relpath,rm,rmdir,seq,shred,shuf,sleep,stat,stdbuf,sum,sync,tac,tee,timeout,touch,tr,true,truncate,tsort,tty,uname,unexpand,uniq,unlink,uptime,users,wc,who,whoami,yes"
+ make
+}
+
+package() {
+ # Install uutils-coreutils
+ cd $_pkgname-$__pkgver
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ MANDIR=/share/man/man1 \
+ PROG_PREFIX= \
+ install
+
+ # Install GNU coreutils over the uutils-coreutils
+ cd $srcdir && cd $_pkgname-$_pkgver
+ make DESTDIR="$pkgdir" install
+
+ # Clean conflicts
+ cd $pkgdir/usr/bin
+ rm groups hostname kill more uptime
+}