summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNico Jensch2023-10-17 08:41:06 +0200
committerNico Jensch2023-10-17 08:41:06 +0200
commit8ed393e5530df5934734ef2c9d0df84888294787 (patch)
tree8d9a3411b73956441f26e1f93420bf6b9bd142a3
parent298f88705d29cbb1d699542d5637a605898ae650 (diff)
downloadaur-8ed393e5530df5934734ef2c9d0df84888294787.tar.gz
chore: update uutils 0.0.22
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c16f2598d3f6..90935481ab0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coreutils-hybrid
pkgdesc = GNU coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished / buggy
- pkgver = 9.1_0.0.21
+ pkgver = 9.1_0.0.22
pkgrel = 1
url = https://www.gnu.org/software/coreutils/
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = coreutils-hybrid
provides = coreutils
conflicts = coreutils
source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.1.tar.xz
- source = uutils-coreutils-0.0.21.tar.gz::https://github.com/uutils/coreutils/archive/0.0.21.tar.gz
+ source = uutils-coreutils-0.0.22.tar.gz::https://github.com/uutils/coreutils/archive/0.0.22.tar.gz
sha512sums = a6ee2c549140b189e8c1b35e119d4289ec27244ec0ed9da0ac55202f365a7e33778b1dc7c4e64d1669599ff81a8297fe4f5adbcc8a3a2f75c919a43cd4b9bdfa
- sha512sums = 8c5cd1c3f9f5e41016938295816bcf8bbcc6f74a121bb1ca64464bbebf0862f90929f853731b520a2e5b3c51795cbd70813509086093f6245f4f834cdb158275
+ sha512sums = 1ffbafa0967470ae442741a6d5a89d37561914d1b472ac6e23573599cd58956196656c0c760aaaa4dfc645270387eb3f9f7122e1cb15cff5470bef1e8b8e8ca3
pkgname = coreutils-hybrid
diff --git a/PKGBUILD b/PKGBUILD
index 43d014f9cd83..b77803295280 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=coreutils-hybrid
_pkgname=coreutils
__pkgname=uutils-coreutils
_pkgver=9.1
-__pkgver=0.0.21
+__pkgver=0.0.22
pkgver="$_pkgver"_"$__pkgver"
pkgrel=1
pkgdesc='GNU coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished / buggy'
@@ -21,9 +21,9 @@ conflicts=('coreutils')
provides=('coreutils')
makedepends=('rust' 'cargo')
source=("https://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$_pkgver.tar.xz"
- "$__pkgname-$__pkgver.tar.gz::$_url/archive/$__pkgver.tar.gz")
+ "$__pkgname-$__pkgver.tar.gz::$_url/archive/$__pkgver.tar.gz")
sha512sums=('a6ee2c549140b189e8c1b35e119d4289ec27244ec0ed9da0ac55202f365a7e33778b1dc7c4e64d1669599ff81a8297fe4f5adbcc8a3a2f75c919a43cd4b9bdfa'
- '8c5cd1c3f9f5e41016938295816bcf8bbcc6f74a121bb1ca64464bbebf0862f90929f853731b520a2e5b3c51795cbd70813509086093f6245f4f834cdb158275')
+ '1ffbafa0967470ae442741a6d5a89d37561914d1b472ac6e23573599cd58956196656c0c760aaaa4dfc645270387eb3f9f7122e1cb15cff5470bef1e8b8e8ca3')
prepare() {
cd $_pkgname-$_pkgver
@@ -42,26 +42,26 @@ build() {
# Build GNU coreutils without the stable uutils programs counterparts leaving out: stat, touch, realpath (genfstab broken), ln (no -s option)
cd $_pkgname-$_pkgver
./configure \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --with-openssl \
- --enable-no-install-program="groups,hostname,kill,uptime,arch,base32,base64,basename,cat,chgrp,chmod,chown,chroot,cksum,comm,csplit,cut,dircolors,dirname,du,env,echo,expand,factor,false,fmt,fold,groups,head,hostid,hostname,id,kill,link,logname,mkdir,mkfifo,mknod,mktemp,mv,nice,nl,nohup,nproc,paste,pathk,pinky,printenv,ptx,pwd,readlink,relpath,rm,rmdir,seq,shred,shuf,sleep,stdbuf,sum,sync,tac,tee,timeout,tr,true,truncate,tsort,tty,uname,unexpand,uniq,unlink,uptime,users,who,wc,whoami,yes"
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-openssl \
+ --enable-no-install-program="groups,hostname,kill,uptime,arch,base32,base64,basename,cat,chgrp,chmod,chown,chroot,cksum,comm,csplit,cut,dircolors,dirname,du,env,echo,expand,factor,false,fmt,fold,groups,head,hostid,hostname,id,kill,link,logname,mkdir,mkfifo,mknod,mktemp,mv,nice,nl,nohup,nproc,paste,pathk,pinky,printenv,ptx,pwd,readlink,relpath,rm,rmdir,seq,shred,shuf,sleep,stdbuf,sum,sync,tac,tee,timeout,tr,true,truncate,tsort,tty,uname,unexpand,uniq,unlink,uptime,users,who,wc,whoami,yes"
}
package() {
# Install uutils-coreutils, skip the buggy parts
cd $_pkgname-$__pkgver
make \
- DESTDIR="$pkgdir" \
- PREFIX=/usr \
- MANDIR=/share/man/man1 \
- PROG_PREFIX= \
- install
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ MANDIR=/share/man/man1 \
+ PROG_PREFIX= \
+ install
# Install GNU coreutils over the uutils-coreutils
cd $srcdir && cd $_pkgname-$_pkgver
make DESTDIR="$pkgdir" install
-
+
# Clean conflicts, Arch ships these in other apps
cd $pkgdir/usr/bin
rm groups hostname kill more uptime