summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThom Wiggers2019-01-24 17:11:57 +0100
committerThom Wiggers2019-01-24 17:11:57 +0100
commit79d733dee55fc1f61f6fa511eb20519702a75d55 (patch)
tree8244e5794ff7704c06a37bde5e14398ad517d7c8
downloadaur-79d733dee55fc1f61f6fa511eb20519702a75d55.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--0001-Marie-Kondo.patch32
-rw-r--r--PKGBUILD59
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9938366f9fd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = coreutils-kondo
+ pkgdesc = The basic file, shell and text manipulation utilities of the GNU operating system, with extra joy.
+ pkgver = 8.30
+ pkgrel = 1
+ url = https://www.gnu.org/software/coreutils/
+ arch = x86_64
+ groups = base
+ license = GPL3
+ depends = glibc
+ depends = acl
+ depends = attr
+ depends = gmp
+ depends = libcap
+ depends = openssl
+ provides = coreutils
+ conflicts = coreutils
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-8.30.tar.xz
+ source = 0001-Marie-Kondo.patch
+ md5sums = ab06d68949758971fe744db66b572816
+ md5sums = SKIP
+
+pkgname = coreutils-kondo
+
diff --git a/0001-Marie-Kondo.patch b/0001-Marie-Kondo.patch
new file mode 100644
index 000000000000..e5232619d9d5
--- /dev/null
+++ b/0001-Marie-Kondo.patch
@@ -0,0 +1,32 @@
+From 3e8294b50a34d7060ec0636afb1a7ad9e448db5b Mon Sep 17 00:00:00 2001
+From: Thom Wiggers <thom@thomwiggers.nl>
+Date: Thu, 24 Jan 2019 16:09:37 +0100
+Subject: [PATCH] Marie Kondo
+
+---
+ src/remove.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/remove.c b/src/remove.c
+index 8102d4e..74ff93e 100644
+--- a/src/remove.c
++++ b/src/remove.c
+@@ -288,12 +288,12 @@ prompt (FTS const *fts, FTSENT const *ent, bool is_dir,
+ problems, it may be more convenient to translate these
+ strings instead as: "%1$s: %3$s is write-protected and
+ is of type '%2$s' -- remove it? ". */
+- ? _("%s: remove write-protected %s %s? ")
+- : _("%s: remove %s %s? ")),
++ ? _("%s: does write-protected %s %s spark joy? ")
++ : _("%s: does %s %s spark joy? ")),
+ program_name, file_type (sbuf), quoted_name);
+ }
+
+- if (!yesno ())
++ if (yesno ())
+ return RM_USER_DECLINED;
+ }
+ return RM_OK;
+--
+2.20.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d60b843760b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# I don't know if conflicting coreutils will result in massive pain.
+#
+# Original maintainers can't be blamed for this.
+# Maintainer: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=coreutils-kondo
+pkgver=8.30
+pkgrel=1
+pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system, with extra joy.'
+arch=('x86_64')
+license=('GPL3')
+url='https://www.gnu.org/software/coreutils/'
+groups=('base')
+conflicts=('coreutils')
+provides=('coreutils')
+depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
+source=("https://ftp.gnu.org/gnu/coreutils/coreutils-$pkgver.tar.xz"
+ "0001-Marie-Kondo.patch"
+ )
+md5sums=('ab06d68949758971fe744db66b572816'
+ 'SKIP')
+
+prepare() {
+ cd coreutils-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd coreutils-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-openssl \
+ --enable-no-install-program=groups,hostname,kill,uptime
+ make
+}
+
+check() {
+ cd coreutils-$pkgver
+ #make check
+}
+
+package() {
+ cd coreutils-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: