summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2015-05-30 10:10:03 +0800
committerNicolas Iooss2015-06-27 12:01:20 +0800
commit1da3c44ea99118f42346e82be25fc89dc5755301 (patch)
treed3bda83ffcb8f336baa86ea22823e354580b679d
parent2873fda6abe22fef37916ffe22b6b4beb551616c (diff)
downloadaur-1da3c44ea99118f42346e82be25fc89dc5755301.tar.gz
coreutils-selinux 8.23-3 update
-rw-r--r--.SRCINFO10
-rw-r--r--0001-cp-don-t-reserve-a-device-number.patch77
-rw-r--r--01-btrfs-alloc.patch96
-rw-r--r--PKGBUILD37
4 files changed, 125 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6849107784ae..e9e314fe8574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coreutils-selinux
pkgdesc = The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support
pkgver = 8.23
- pkgrel = 2
+ pkgrel = 3
url = http://www.gnu.org/software/coreutils
install = coreutils.install
arch = i686
@@ -9,20 +9,22 @@ pkgbase = coreutils-selinux
groups = selinux
license = GPL3
depends = glibc
- depends = pam-selinux
depends = acl
+ depends = attr
depends = gmp
depends = libcap
depends = openssl
depends = libselinux
- provides = coreutils=8.23-2
- provides = selinux-coreutils=8.23-2
+ provides = coreutils=8.23-3
+ provides = selinux-coreutils=8.23-3
conflicts = coreutils
conflicts = selinux-coreutils
source = ftp://ftp.gnu.org/gnu/coreutils/coreutils-8.23.tar.xz
source = ftp://ftp.gnu.org/gnu/coreutils/coreutils-8.23.tar.xz.sig
+ source = 01-btrfs-alloc.patch
md5sums = abed135279f87ad6762ce57ff6d89c41
md5sums = SKIP
+ md5sums = 7333cea9afddff017dd0445fc5b8cc8f
pkgname = coreutils-selinux
diff --git a/0001-cp-don-t-reserve-a-device-number.patch b/0001-cp-don-t-reserve-a-device-number.patch
deleted file mode 100644
index 1f276b4a49d8..000000000000
--- a/0001-cp-don-t-reserve-a-device-number.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From d0294ff3b90430750a631556277c75f1a555dd44 Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Thu, 3 Apr 2014 09:48:22 -0700
-Subject: [PATCH] cp: don't reserve a device number
-
-* src/copy.c (copy_internal): Replace dev_t arg DEVICE with struct
-stat pointer arg PARENT. All callers changed. This removes an
-unwarranted assumption that dev_t values of 0 cannot occur in file
-systems. See: http://bugs.gnu.org/17179
----
- src/copy.c | 15 +++++++--------
- 1 file changed, 7 insertions(+), 8 deletions(-)
-
-diff --git a/src/copy.c b/src/copy.c
-index 781cc1e..d471a77 100644
---- a/src/copy.c
-+++ b/src/copy.c
-@@ -117,7 +117,7 @@ struct dir_list
- #define DEST_INFO_INITIAL_CAPACITY 61
-
- static bool copy_internal (char const *src_name, char const *dst_name,
-- bool new_dst, dev_t device,
-+ bool new_dst, struct stat const *parent,
- struct dir_list *ancestors,
- const struct cp_options *x,
- bool command_line_arg,
-@@ -621,7 +621,7 @@ copy_dir (char const *src_name_in, char const *dst_name_in, bool new_dst,
- char *dst_name = file_name_concat (dst_name_in, namep, NULL);
- bool first_dir_created = *first_dir_created_per_command_line_arg;
-
-- ok &= copy_internal (src_name, dst_name, new_dst, src_sb->st_dev,
-+ ok &= copy_internal (src_name, dst_name, new_dst, src_sb,
- ancestors, &non_command_line_options, false,
- &first_dir_created,
- &local_copy_into_self, NULL);
-@@ -1725,9 +1725,8 @@ should_dereference (const struct cp_options *x, bool command_line_arg)
- /* Copy the file SRC_NAME to the file DST_NAME. The files may be of
- any type. NEW_DST should be true if the file DST_NAME cannot
- exist because its parent directory was just created; NEW_DST should
-- be false if DST_NAME might already exist. DEVICE is the device
-- number of the parent directory, or 0 if the parent of this file is
-- not known. ANCESTORS points to a linked, null terminated list of
-+ be false if DST_NAME might already exist. A nonnull PARENT describes the
-+ parent directory. ANCESTORS points to a linked, null terminated list of
- devices and inodes of parent directories of SRC_NAME. COMMAND_LINE_ARG
- is true iff SRC_NAME was specified on the command line.
- FIRST_DIR_CREATED_PER_COMMAND_LINE_ARG is both input and output.
-@@ -1737,7 +1736,7 @@ should_dereference (const struct cp_options *x, bool command_line_arg)
- static bool
- copy_internal (char const *src_name, char const *dst_name,
- bool new_dst,
-- dev_t device,
-+ struct stat const *parent,
- struct dir_list *ancestors,
- const struct cp_options *x,
- bool command_line_arg,
-@@ -2434,7 +2433,7 @@ copy_internal (char const *src_name, char const *dst_name,
- }
-
- /* Decide whether to copy the contents of the directory. */
-- if (x->one_file_system && device != 0 && device != src_sb.st_dev)
-+ if (x->one_file_system && parent && parent->st_dev != src_sb.st_dev)
- {
- /* Here, we are crossing a file system boundary and cp's -x option
- is in effect: so don't copy the contents of this directory. */
-@@ -2827,7 +2826,7 @@ copy (char const *src_name, char const *dst_name,
- top_level_dst_name = dst_name;
-
- bool first_dir_created_per_command_line_arg = false;
-- return copy_internal (src_name, dst_name, nonexistent_dst, 0, NULL,
-+ return copy_internal (src_name, dst_name, nonexistent_dst, NULL, NULL,
- options, true,
- &first_dir_created_per_command_line_arg,
- copy_into_self, rename_succeeded);
---
-1.9.1
-
diff --git a/01-btrfs-alloc.patch b/01-btrfs-alloc.patch
new file mode 100644
index 000000000000..78424f18faad
--- /dev/null
+++ b/01-btrfs-alloc.patch
@@ -0,0 +1,96 @@
+#http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20570
+
+diff --git a/tests/cp/fiemap-empty.sh b/tests/cp/fiemap-empty.sh
+index a5eaac5..b3b2cd7 100755
+--- a/tests/cp/fiemap-empty.sh
++++ b/tests/cp/fiemap-empty.sh
+@@ -22,6 +22,7 @@ print_ver_ cp
+ # FIXME: enable any part of this test that is still relevant,
+ # or, if none are relevant (now that cp does not handle unwritten
+ # extents), just remove the test altogether.
++# Note also if checking allocations may need to sync first on BTRFS at least
+ skip_ 'disabled for now'
+
+ touch fiemap_chk
+diff --git a/tests/dd/sparse.sh b/tests/dd/sparse.sh
+index 4fdabad..626b405 100755
+--- a/tests/dd/sparse.sh
++++ b/tests/dd/sparse.sh
+@@ -17,6 +17,7 @@
+
+ . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
+ print_ver_ dd
++is_local_dir_ . || very_expensive_
+ require_sparse_support_
+
+ # Ensure basic sparse generation works
+@@ -50,6 +51,9 @@ dd if=/dev/zero of=file.in bs=1M count=1 seek=1 conv=notrunc || fail=1
+
+ kb_alloc() { du -k "$1"|cut -f1; }
+
++# sync out data for async allocators like NFS/BTRFS
++# sync file.in || fail=1
++
+ # If our just-created input file appears to be too small,
+ # skip the remaining tests. On at least Solaris 10 with NFS,
+ # file.in is reported to occupy <= 1KiB for about 50 seconds
+@@ -58,7 +62,10 @@ if test $(kb_alloc file.in) -gt 3000; then
+
+ # Ensure NUL blocks smaller than the block size are not made sparse.
+ # Here, with a 2MiB block size, dd's conv=sparse must *not* introduce a hole.
+- dd if=file.in of=file.out bs=2M conv=sparse
++ dd if=file.in of=file.out bs=2M conv=sparse || fail=1
++
++ # Intermittently BTRFS returns 0 allocation for file.out unless synced
++ sync file.out || framework_failure_
+ test 2500 -lt $(kb_alloc file.out) || fail=1
+
+ # Note we recreate a sparse file first to avoid
+diff --git a/tests/du/2g.sh b/tests/du/2g.sh
+index 5f04488..12c2eed 100755
+--- a/tests/du/2g.sh
++++ b/tests/du/2g.sh
+@@ -24,7 +24,6 @@ print_ver_ du
+ # Creating a 2GB file counts as 'very expensive'.
+ very_expensive_
+
+-
+ # Get number of free kilobytes on current partition, so we can
+ # skip this test if there is insufficient free space.
+ free_kb=$(df -k --output=avail . | tail -n1)
+@@ -42,16 +42,21 @@
+ }
+
+ big=big
+-rm -f $big
+-test -t 1 || printf 'creating a 2GB file...\n'
+-for i in $(seq 100); do
+- # Note: 2147483648 == 2^31. Print floor(2^31/100) per iteration.
+- printf %21474836s x >> $big || fail=1
+- # On the final iteration, append the remaining 48 bytes.
+- test $i = 100 && { printf %48s x >> $big || fail=1; }
+- test -t 1 && printf 'creating a 2GB file: %d%% complete\r' $i
+-done
+-echo
++if ! fallocate -l2G $big; then
++ rm -f $big
++ {
++ is_local_dir_ . || skip 'Not writing 2GB data to remote'
++ for i in $(seq 100); do
++ # Note: 2147483648 == 2^31. Print floor(2^31/100) per iteration.
++ printf %21474836s x || fail=1
++ done
++ # After the final iteration, append the remaining 48 bytes.
++ printf %48s x || fail=1
++ } > $big || fail=1
++fi
++
++# The allocation may be done asynchronously (BTRFS for example)
++sync $big || framework_failure_
+
+ du -k $big > out1 || fail=1
+ rm -f $big
+--
+2.3.4
+
+
diff --git a/PKGBUILD b/PKGBUILD
index 98dc6125d9ee..413e5c7803bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# $Id$
-# Maintainer: Sébastien "Seblu" Luttringer
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
@@ -9,29 +9,36 @@
pkgname=coreutils-selinux
pkgver=8.23
-pkgrel=2
-pkgdesc="The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support"
+pkgrel=3
+pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support'
arch=('i686' 'x86_64')
license=('GPL3')
-url="http://www.gnu.org/software/coreutils"
+url='http://www.gnu.org/software/coreutils'
groups=('selinux')
-depends=('glibc' 'pam-selinux' 'acl' 'gmp' 'libcap' 'openssl' 'libselinux')
+depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl' 'libselinux')
install=${pkgname/-selinux}.install
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9')
-source=("ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig})
+source=("ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig}
+ '01-btrfs-alloc.patch')
+validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
md5sums=('abed135279f87ad6762ce57ff6d89c41'
- 'SKIP')
+ 'SKIP'
+ '7333cea9afddff017dd0445fc5b8cc8f')
-#prepare() {
-# cd $pkgname-$pkgver
-#}
+prepare() {
+ local _p
+ for _p in *.patch; do
+ [[ -e $_p ]] || continue
+ msg2 "Applying $_p"
+ patch -p1 -d ${pkgname/-selinux}-$pkgver < "$_p"
+ done
+}
build() {
cd ${pkgname/-selinux}-$pkgver
- ./configure \
+ ./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
--with-openssl \
@@ -42,10 +49,12 @@ build() {
check() {
cd ${pkgname/-selinux}-$pkgver
- make RUN_EXPENSIVE_TESTS=yes check
+ RUN_VERY_EXPENSIVE_TESTS=yes make check
}
package() {
cd ${pkgname/-selinux}-$pkgver
make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=2 sw=2 et: