summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetscoin2018-06-08 21:42:36 -0400
committermetscoin2018-06-08 21:42:36 -0400
commitf57ce3f92c95d60dd81ea24701f52d3b7ed1c881 (patch)
treef8d322054c72197e35230ece40c21076c59bb962
downloadaur-f57ce3f92c95d60dd81ea24701f52d3b7ed1c881.tar.gz
Init corez-qt repo
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
-rw-r--r--corez-qt.desktop11
-rw-r--r--corez-qt.install11
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a044bad6dba8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = corez-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 0.12.1
+ pkgrel = 3
+ url = http://corez.site/
+ install = corez-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = corez
+ source = corez-qt::git+http://github.com/corezcrypto/corez.git
+ source = corez-qt.desktop
+ sha256sums = SKIP
+ sha256sums = 09b0e17970b210dab6fcc4389ac0454a6310f85e45710af06ddbfebb923881f3
+
+pkgname = corez-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7707bb430e42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=corez-qt
+pkgver=0.12.1
+pkgrel=3
+arch=('i686' 'x86_64')
+url="http://corez.site/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(corez)
+install=corez-qt.install
+source=("${pkgname%-git}::git+http://github.com/corezcrypto/corez.git"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ '09b0e17970b210dab6fcc4389ac0454a6310f85e45710af06ddbfebb923881f3')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure --with-gui=qt5
+ make
+}
+
+
+package() {
+ install -Dm644 corez-qt.desktop "$pkgdir"/usr/share/applications/corez.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/corez-qt "$pkgdir"/usr/bin/corez-qt
+ install -Dm644 share/pixmaps/corez128.png "$pkgdir"/usr/share/pixmaps/corez128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/corez-qt.desktop b/corez-qt.desktop
new file mode 100644
index 000000000000..8827502f6c6d
--- /dev/null
+++ b/corez-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Corez
+Comment=Corez P2P Cryptocurrency
+Exec=/usr/bin/corez-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/corez128.png
+MimeType=x-scheme-handler/corez;
+Categories=Office;
+Name[en_US]=corez-qt.desktop
diff --git a/corez-qt.install b/corez-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/corez-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}