aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMotorTruck12212024-03-09 03:29:31 -0700
committerMotorTruck12212024-03-09 03:29:31 -0700
commit86c92264f99e0b4cfc89fb90de65350492d85380 (patch)
tree87925c4fc9b9bec39910660feaab77b955d40b54
downloadaur-86c92264f99e0b4cfc89fb90de65350492d85380.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fd1521658d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = corlink-server-git
+ pkgdesc = The corlink licensing server for the corlink project.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/ruby-network/corlink
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = make
+ depends = go
+ depends = upx
+ provides = corlink-server
+ conflicts = corlink-server
+ source = git+https://github.com/ruby-network/corlink
+ sha256sums = SKIP
+
+pkgname = corlink-server-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feb0da48dde1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: MotorTruck1221 motortruck1221@protonmail.com
+
+pkgname=corlink-server-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="The corlink licensing server for the corlink project."
+url="https://github.com/ruby-network/corlink/license"
+arch=('x86_64')
+license=('GPL3')
+depends=('make' 'go' 'upx')
+makedepends=('git')
+provides=('corlink-server')
+license=('GPL3')
+conflicts=('corlink-server')
+url="https://github.com/ruby-network/corlink"
+source=("git+$url")
+sha256sums=('SKIP')
+package() {
+ cd "${srcdir}/corlink/license"
+ make default
+ make compress
+ install -Dm755 "${srcdir}/corlink/license/bin/corlink-server" "${pkgdir}/usr/bin/corlink-server"
+}