summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-12-07 03:09:12 -0700
committerBrian Bidulock2016-12-07 03:09:12 -0700
commitdc0c29f7c3f4fdeac5e726e3d554595bc3495356 (patch)
tree0a0f1f306608d63362e0843b993a0d3349a97b64
parent7ecdd8cdb457f9704b619350b4e4ab6b9a42f2a0 (diff)
downloadaur-dc0c29f7c3f4fdeac5e726e3d554595bc3495356.tar.gz
version 2.4.2.r8.gd6c7ade-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e035748d078c..554ae8a2e8ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,19 @@
pkgbase = corosync-git
pkgdesc = Cluster engine for nodal communication systems with additional features for implementing high availability within applications.
- pkgver = 2.4.1.r36.g4939c75
- pkgrel = 3
+ pkgver = 2.4.2.r8.gd6c7ade
+ pkgrel = 1
url = http://www.corosync.org/
arch = i686
arch = x86_64
license = BSD
makedepends = git
- depends = nss
depends = libstatgrab
depends = net-snmp
depends = libdbus
- depends = libqb-git
- depends = kronosnet-git
provides = corosync
- conflicts = corosync1
conflicts = corosync
- source = corosync-git::git+https://github.com/corosync/corosync.git
- source = corosync.service
+ source = corosync-git::git+https://github.com/corosync/corosync.git#branch=needle
md5sums = SKIP
- md5sums = 93d77bf4963852cf842497d5da92dc82
pkgname = corosync-git
diff --git a/PKGBUILD b/PKGBUILD
index f045def063cc..7de331b86ae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
# Contributor: ovi chis <sonekken@gmail.com>
pkgname=corosync-git
-pkgver=2.4.1.r36.g4939c75
-pkgrel=3
+_pkgname=corosync
+pkgver=2.4.2.r8.gd6c7ade
+pkgrel=1
pkgdesc="Cluster engine for nodal communication systems with additional features for implementing high availability within applications."
arch=('i686' 'x86_64')
url="http://www.corosync.org/"
license=('BSD')
makedepends=('git')
-depends=('nss' 'libstatgrab' 'net-snmp' 'libdbus' 'libqb-git' 'kronosnet-git')
-provides=('corosync')
-conflicts=('corosync1' 'corosync')
-source=("$pkgname::git+https://github.com/corosync/corosync.git"
- "corosync.service")
+depends=('libstatgrab' 'net-snmp' 'libdbus')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("$pkgname::git+https://github.com/corosync/${_pkgname}.git#branch=needle")
+md5sums=('SKIP')
pkgver() {
cd $pkgname
@@ -22,8 +23,7 @@ pkgver() {
prepare() {
cd $pkgname
- mkdir -p m4
- autoreconf -fiv
+ ./autogen.sh
}
build() {
@@ -36,9 +36,9 @@ build() {
--enable-monitoring \
--enable-watchdog \
--enable-systemd \
- --disable-upstart \
+ --disable-upstart \
--enable-snmp \
- --enable-xmlconf \
+ --enable-xmlconf \
--with-systemddir=/usr/lib/systemd/system \
--with-tmpfilesdir=/usr/lib/tmpfiles.d
make V=0
@@ -48,7 +48,10 @@ package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ rm -fr "${pkgdir}/var/log"
+ install -Dm644 /dev/null "${pkgdir}/usr/lib/tmpfiles.d/corosync.conf"
+ echo "d /var/log/cluster 0755 root root -" \
+ >"${pkgdir}/usr/lib/tmpfiles.d/corosync.conf"
}
-md5sums=('SKIP'
- '93d77bf4963852cf842497d5da92dc82')
+# vim: set sw=2 et: