summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-06-17 00:47:29 +0200
committerNarrat2015-06-17 00:47:29 +0200
commite8607f76f96d084e955301bff77192be21ec60e2 (patch)
tree1db6278402ec5ffab238e5beef30e31c3b8b978b
downloadaur-e8607f76f96d084e955301bff77192be21ec60e2.tar.gz
Adopted AUR3 package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65d64574b67b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = correcthorse
+ pkgdesc = Passphrase generator based on http://xkcd.com/936/
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/rmartinjak/correcthorse
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ source = http://rmartinjak.de/correcthorse/correcthorse-1.0.tar.gz
+ md5sums = 3d691f786f5879f5b902585472d6d195
+
+pkgname = correcthorse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f5a385a0261b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.asc
+*.bz2
+*.gz
+*.log
+*.part
+*.pkg
+pkg/
+*.scm
+*.sig
+*.sign
+src/
+*.txt
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdbd6604ffbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Robin Martinjak <rob@rmartinjak.de>
+pkgname=correcthorse
+pkgver=1.0
+pkgrel=1
+pkgdesc="Passphrase generator based on http://xkcd.com/936/"
+arch=('i686' 'x86_64')
+url="https://github.com/rmartinjak/correcthorse"
+license=('WTFPL')
+source=(http://rmartinjak.de/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('3d691f786f5879f5b902585472d6d195')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+}
+
+# vim:set ts=2 sw=2 et: