aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Kes2019-03-24 13:56:14 +0100
committerRyan Kes2019-03-24 13:56:14 +0100
commit28a18006b1acd0c396d51358ad582be528d72279 (patch)
treeaee982f96eec47a689258b483b248862c425fbde
downloadaur-28a18006b1acd0c396d51358ad582be528d72279.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d06fd29b6c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = corrupter-git
+ pkgdesc = Simple image glitcher suitable for producing nice looking i3lock backgrounds
+ pkgver = r21.b8b55be
+ pkgrel = 1
+ url = https://github.com/r00tman/corrupter
+ arch = i686
+ arch = x86_64
+ license = custom:ISC
+ makedepends = git
+ makedepends = go
+ depends = libx11
+ depends = notmuch
+ source = git+https://github.com/r00tman/corrupter
+ md5sums = SKIP
+
+pkgname = corrupter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0168c753667a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ryan Kes <alrayyes@gmail.com>
+
+pkgname=corrupter-git
+pkgver=r21.b8b55be
+pkgrel=1
+pkgdesc='Simple image glitcher suitable for producing nice looking i3lock backgrounds'
+arch=('i686' 'x86_64')
+url='https://github.com/r00tman/corrupter'
+depends=('libx11' 'notmuch')
+makedepends=('git' 'go')
+license=('custom:ISC')
+
+md5sums=('SKIP')
+
+source=("git+https://github.com/r00tman/${pkgname%-git}")
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "${pkgname%-git}"
+ go build
+}
+
+package() {
+ cd "${pkgname%-git}"
+
+ install -Dm755 corrupter "${pkgdir}/usr/bin/corrupter"
+# install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+}