aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Kes2019-03-24 14:11:46 +0100
committerRyan Kes2019-03-24 14:11:46 +0100
commitd367f94e1f6b3e8a36b1efb5589494a4fed58f86 (patch)
treef1d35fed654ed97deddae7b564e90e05d5cc58d4
parent28a18006b1acd0c396d51358ad582be528d72279 (diff)
downloadaur-d367f94e1f6b3e8a36b1efb5589494a4fed58f86.tar.gz
removed dependencies
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD7
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d06fd29b6c9..8f5bc4959283 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,6 @@ pkgbase = corrupter-git
license = custom:ISC
makedepends = git
makedepends = go
- depends = libx11
- depends = notmuch
source = git+https://github.com/r00tman/corrupter
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..986a577eb3eb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+corrupter/
diff --git a/PKGBUILD b/PKGBUILD
index 0168c753667a..83b9db28a25e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,6 @@ pkgrel=1
pkgdesc='Simple image glitcher suitable for producing nice looking i3lock backgrounds'
arch=('i686' 'x86_64')
url='https://github.com/r00tman/corrupter'
-depends=('libx11' 'notmuch')
makedepends=('git' 'go')
license=('custom:ISC')
@@ -15,18 +14,18 @@ md5sums=('SKIP')
source=("git+https://github.com/r00tman/${pkgname%-git}")
pkgver() {
- cd "${pkgname%-git}"
+ cd "$srcdir"/"${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${pkgname%-git}"
+ cd "$srcdir"/"${pkgname%-git}"
go build
}
package() {
- cd "${pkgname%-git}"
+ cd "$srcdir"/"${pkgname%-git}"
install -Dm755 corrupter "${pkgdir}/usr/bin/corrupter"
# install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"