summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranck STAUFFER2020-09-12 14:43:35 +0200
committerFranck STAUFFER2020-09-12 14:43:35 +0200
commit73b5914b2d11b0c4f69d76ad9fc34dcfe5a72391 (patch)
tree720c6297829483198c53289cf8b743450fcb43dc
downloadaur-73b5914b2d11b0c4f69d76ad9fc34dcfe5a72391.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--cos-git.desktop10
-rw-r--r--cos-git.pngbin0 -> 16367 bytes
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a41ba160c49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cos-git
+ pkgdesc = Children of Solarus - 100% free remake of The Legend of Zelda: Mystery of Solarus DX (Git version)
+ pkgver = r2051.c2dc1ad3
+ pkgrel = 1
+ url = https://solarus-games.org/en/games/children-of-solarus
+ arch = any
+ license = GPL3
+ license = custom
+ makedepends = cmake
+ makedepends = zip
+ depends = solarus>=1.6.0
+ source = cos-git::git+https://gitlab.com/solarus-games/children-of-solarus.git
+ source = cos-git.png
+ source = cos-git.desktop
+ b2sums = SKIP
+ b2sums = 246f69fd275711cceb42e1d6cadbb47c82f75d6b0cff4ac4d17554f53a118a4adc6d72887960e5f2397a6734b09b9676f9dac27e0cc4203911d0c192720b3371
+ b2sums = 9c950ca2d10077c94fb5aa080d2f3d6fb46869c33a16ac443197647e5cf2b9318e58be04310538647e2ed9fdbee09758dca9b3e018f34da442501bf1cdc685af
+
+pkgname = cos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bce38327739
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Franck STAUFFER <franck.stauffer@monaco.mc>
+
+pkgname=cos-git
+pkgver=r2051.c2dc1ad3
+pkgrel=1
+pkgdesc='Children of Solarus - 100% free remake of The Legend of Zelda: Mystery of Solarus DX (Git version)'
+arch=('any')
+url='https://solarus-games.org/en/games/children-of-solarus'
+license=('GPL3' 'custom')
+depends=('solarus>=1.6.0')
+makedepends=('cmake' 'zip')
+source=("$pkgname::git+https://gitlab.com/solarus-games/children-of-solarus.git"
+ "$pkgname.png"
+ "$pkgname.desktop")
+b2sums=('SKIP'
+ '246f69fd275711cceb42e1d6cadbb47c82f75d6b0cff4ac4d17554f53a118a4adc6d72887960e5f2397a6734b09b9676f9dac27e0cc4203911d0c192720b3371'
+ '9c950ca2d10077c94fb5aa080d2f3d6fb46869c33a16ac443197647e5cf2b9318e58be04310538647e2ed9fdbee09758dca9b3e018f34da442501bf1cdc685af')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+ sed -i 's/set(quest_name "ChildrenOfSolarus")/set(quest_name "cos-git")/' "$pkgname/CMakeLists.txt"
+}
+
+build() {
+ cd "$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' .
+ make
+}
+
+package() {
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/cos-git.desktop b/cos-git.desktop
new file mode 100644
index 000000000000..1776aef75b96
--- /dev/null
+++ b/cos-git.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Children of Solarus (Git version)
+Comment=100% free remake of The Legend of Zelda: Mystery of Solarus DX
+Path=/usr/bin
+Exec=cos-git
+Icon=cos-git
+Terminal=false
+Categories=Game;
diff --git a/cos-git.png b/cos-git.png
new file mode 100644
index 000000000000..4eb0c8108b07
--- /dev/null
+++ b/cos-git.png
Binary files differ