summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeidnx2023-01-11 11:25:56 +0100
committerJeidnx2023-01-11 11:25:56 +0100
commite3cf67330f2ece4197ddb5dfce0be3d647fc7045 (patch)
tree10da67e8e752418e49d775a3d1e8acd91794003d
downloadaur-e3cf67330f2ece4197ddb5dfce0be3d647fc7045.tar.gz
First upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8f36bc0cfca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = coshr-git
+ pkgdesc = Easily share the output of your commands
+ pkgver = r1.b2103b7
+ pkgrel = 1
+ url = https://github.com/Jeidnx/coshr
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = wl-clipboard
+ depends = bash
+ provides = coshr
+ conflicts = coshr
+ source = git+https://github.com/Jeidnx/coshr
+ md5sums = SKIP
+
+pkgname = coshr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79ffc2533d2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jeidnx <jeidnx@domainhier.de>
+
+pkgname=coshr-git
+pkgver=r1.b2103b7
+pkgrel=1
+pkgdesc="Easily share the output of your commands"
+arch=("any")
+url="https://github.com/Jeidnx/coshr"
+license=('GPL')
+depends=('wl-clipboard' 'bash')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Jeidnx/coshr')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkdir/usr/bin/"
+ install -Dm755 "$srcdir/${pkgname%-git}/coshr.sh" "$pkgdir/usr/bin/coshr"
+}