summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2025-01-28 09:39:38 -0700
committerMark Wagie2025-01-28 09:39:38 -0700
commit037132542742c85f8aafcbf4eb7b024e6dde1498 (patch)
tree39ee79d830f06fe0e66c72621e01fef2f159d560
downloadaur-cosmic-ext-applet-emoji-selector-git.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore9
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD45
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac9fb503ee8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cosmic-ext-applet-emoji-selector-git
+ pkgdesc = Emoji Selector for COSMIC™️ DE
+ pkgver = 0.1.5.r38.g1b2eb23
+ pkgrel = 1
+ url = https://github.com/leb-kuchen/cosmic-ext-applet-emoji-selector
+ arch = x86_64
+ license = MPL-2.0 AND MIT
+ makedepends = cargo
+ makedepends = git
+ makedepends = just
+ depends = cosmic-applets
+ depends = noto-fonts-emoji
+ provides = cosmic-ext-applet-emoji-selector
+ conflicts = cosmic-ext-applet-emoji-selector
+ conflicts = cosmic-applet-emoji-selector-git
+ conflicts = emoji-selector-applet-for-cosmic-git
+ source = git+https://github.com/leb-kuchen/cosmic-ext-applet-emoji-selector.git
+ sha256sums = SKIP
+
+pkgname = cosmic-ext-applet-emoji-selector-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fbf13ff84003
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore everything
+/*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!.nvchecker.toml
+!LICENSE
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..733e88560b9d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f441e557645c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=cosmic-ext-applet-emoji-selector-git
+pkgver=0.1.5.r38.g1b2eb23
+pkgrel=1
+pkgdesc="Emoji Selector for COSMIC™️ DE"
+arch=('x86_64')
+url="https://github.com/leb-kuchen/cosmic-ext-applet-emoji-selector"
+license=('MPL-2.0 AND MIT')
+depends=(
+ 'cosmic-applets'
+ 'noto-fonts-emoji'
+)
+makedepends=(
+ 'cargo'
+ 'git'
+ 'just'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'cosmic-applet-emoji-selector-git' 'emoji-selector-applet-for-cosmic-git')
+source=('git+https://github.com/leb-kuchen/cosmic-ext-applet-emoji-selector.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ just build-release
+}
+
+package() {
+ cd "${pkgname%-git}"
+ just rootdir="$pkgdir" install
+
+ install -Dm644 LICENSE-MIT -t "$pkgdir/usr/share/licenses/$pkgname/"
+}