summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-09-26 12:16:56 -0600
committerMark Wagie2024-09-26 12:16:56 -0600
commit36ba3b4f59eddf14b56fabcd68ee4573d81426cd (patch)
tree23f58e7f5c0322945d9b41fb4806132d20df8496
parentd212a1b2967cfd0c801482b98e94dee79c2f37a8 (diff)
downloadaur-36ba3b4f59eddf14b56fabcd68ee4573d81426cd.tar.gz
use thin LTO
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
-rw-r--r--cargo.lock.patch36
-rw-r--r--lto.patch11
5 files changed, 20 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aefa7946201e..c2fd6a1b1ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cosmic-notifications-git
pkgdesc = Layer Shell notifications daemon which integrates with COSMIC.
pkgver = 1.0.0.alpha.1.r0.ge9abef5
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/pop-os/cosmic-notifications
arch = x86_64
arch = aarch64
@@ -17,6 +17,8 @@ pkgbase = cosmic-notifications-git
provides = cosmic-notifications
conflicts = cosmic-notifications
source = git+https://github.com/pop-os/cosmic-notifications.git
+ source = lto.patch
sha256sums = SKIP
+ sha256sums = 4cacb38bd2c25710dc67ba298acb0b6b1cf37e10dee0ea6e34ea72bd9e59b832
pkgname = cosmic-notifications-git
diff --git a/.gitignore b/.gitignore
index 55aa12c745ac..4d685a41c137 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!cargo.lock.patch
+!lto.patch
diff --git a/PKGBUILD b/PKGBUILD
index 756b574d9aa4..36ec4eab45b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: soloturn <soloturn@gmail.com>
pkgname=cosmic-notifications-git
pkgver=1.0.0.alpha.1.r0.ge9abef5
-pkgrel=3
+pkgrel=4
pkgdesc="Layer Shell notifications daemon which integrates with COSMIC."
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/cosmic-notifications"
@@ -21,8 +21,10 @@ makedepends=(
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/pop-os/cosmic-notifications.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/pop-os/cosmic-notifications.git'
+ 'lto.patch')
+sha256sums=('SKIP'
+ '4cacb38bd2c25710dc67ba298acb0b6b1cf37e10dee0ea6e34ea72bd9e59b832')
pkgver() {
cd "${pkgname%-git}"
diff --git a/cargo.lock.patch b/cargo.lock.patch
deleted file mode 100644
index 05e9e593446b..000000000000
--- a/cargo.lock.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- Cargo.lock-a 2024-05-13 11:31:36.918208879 -0600
-+++ Cargo.lock-b 2024-05-13 11:33:35.493642510 -0600
-@@ -4447,33 +4447,6 @@
- ]
-
- [[package]]
--name = "smithay-client-toolkit"
--version = "0.18.0"
--source = "git+https://github.com/smithay/client-toolkit#18070ad8e0675bdf555e6099bf90e3a92adc01b0"
--dependencies = [
-- "bitflags 2.5.0",
-- "bytemuck",
-- "calloop",
-- "calloop-wayland-source",
-- "cursor-icon",
-- "libc",
-- "log",
-- "memmap2 0.9.4",
-- "pkg-config",
-- "rustix 0.38.34",
-- "thiserror",
-- "wayland-backend",
-- "wayland-client",
-- "wayland-csd-frame",
-- "wayland-cursor",
-- "wayland-protocols",
-- "wayland-protocols-wlr",
-- "wayland-scanner",
-- "xkbcommon",
-- "xkeysym",
--]
--
--[[package]]
- name = "smithay-clipboard"
- version = "0.8.0"
- source = "git+https://github.com/pop-os/smithay-clipboard?tag=pop-dnd-4#ab422ddcc95a9a1717df094f9c8fe69e2fdb2a27"
diff --git a/lto.patch b/lto.patch
new file mode 100644
index 000000000000..66568b892b6e
--- /dev/null
+++ b/lto.patch
@@ -0,0 +1,11 @@
+diff '--color=auto' -rupN cosmic-notifications.orig/Cargo.toml cosmic-notifications/Cargo.toml
+--- cosmic-notifications.orig/Cargo.toml 2024-09-26 18:50:44.170054898 +0200
++++ cosmic-notifications/Cargo.toml 2024-09-26 18:51:04.683618139 +0200
+@@ -59,3 +59,7 @@ members = ["cosmic-notifications-util",
+ # [patch.'https://github.com/smithay/client-toolkit/']
+ # smithay-client-toolkit = { git = "https://github.com/smithay/client-toolkit//", rev = "3bed072" }
+ # cosmic-config = { git = "https://github.com/pop-os/libcosmic//" }
++
++[profile.release]
++lto = "thin"
++