summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-05-09 13:27:32 -0600
committerMark Wagie2024-05-09 13:27:32 -0600
commitfebccd726d16e063e8faa5190f61e68f58992614 (patch)
tree8245bc0b4ade3123b7e77a6b38870791bee3eb62
parente98087fa18bcdd667e7efdf6cd2572d4c6252cf3 (diff)
downloadaur-febccd726d16e063e8faa5190f61e68f58992614.tar.gz
don't disable warnings
-rw-r--r--PKGBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7af3f41b97d0..a16bbf015a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,12 +45,8 @@ build() {
cd "${pkgname%-git}"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- # note, consider rust build time optimisations:
- # https://matklad.github.io/2021/09/04/fast-rust-builds.html,
- # later. for now, ignore warnings, and build with lower priority
- # to not block user installing this pkg. to speed up build, use "mold" linker, see
- # https://stackoverflow.com/questions/67511990/how-to-use-the-mold-linker-with-cargo
- RUSTFLAGS="-A warnings -C link-arg=-fuse-ld=mold"
+
+ # use nice to build with lower priority
nice just build-vendored
}