summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-26 08:37:11 -0600
committerMark Wagie2024-03-26 08:37:11 -0600
commit926a82d6833420b7510f11fdd5304300d437401b (patch)
tree82e98e4fc79c9a7fc383ce2823c200650583c4d0
parent18073643b80e8dfb08d719da1432b3158e846d12 (diff)
downloadaur-926a82d6833420b7510f11fdd5304300d437401b.tar.gz
fixes & improvements
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a43a64ba575..f8673d1e61a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cosmic-settings-daemon-git
pkgdesc = WIP COSMIC settings daemon
- pkgver = r25.e87837e
+ pkgver = r39.a949447
pkgrel = 1
url = https://github.com/pop-os/cosmic-settings-daemon
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = cosmic-settings-daemon-git
license = GPL-3.0-or-later
makedepends = cargo
makedepends = git
+ depends = geoclue
depends = systemd-libs
provides = cosmic-settings-daemon
conflicts = cosmic-settings-daemon
diff --git a/PKGBUILD b/PKGBUILD
index fcb471b893d3..2abcf8931a61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=cosmic-settings-daemon-git
-pkgver=r25.e87837e
+pkgver=r39.a949447
pkgrel=1
pkgdesc="WIP COSMIC settings daemon"
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/cosmic-settings-daemon"
license=('GPL-3.0-or-later')
groups=('cosmic')
-depends=('systemd-libs')
+depends=(
+ 'geoclue'
+ 'systemd-libs'
+)
makedepends=(
'cargo'
'git'
@@ -26,8 +29,9 @@ prepare() {
cd "${pkgname%-git}"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
make vendor
+
+ sed -i 's|libexec|lib|g' Makefile src/main.rs
}
build() {