summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-02-20 20:13:14 -0700
committerMark Wagie2024-02-20 20:13:14 -0700
commit4f96885f2722ca45a0efe9b2dc632af7ad898dc3 (patch)
treecc2e879de8b984f99595ded57e2f11dece0ca4f9
downloadaur-4f96885f2722ca45a0efe9b2dc632af7ad898dc3.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD55
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a30419db7e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cosmic-store-git
+ pkgdesc = WIP COSMIC app store
+ pkgver = r64.01eb413
+ pkgrel = 1
+ url = https://github.com/pop-os/cosmic-store
+ arch = x86_64
+ arch = aarch64
+ groups = cosmic
+ license = GPL-3.0-or-later
+ makedepends = cargo
+ makedepends = git
+ makedepends = just
+ depends = flatpak
+ provides = cosmic-store
+ conflicts = cosmic-store
+ source = git+https://github.com/pop-os/cosmic-store.git
+ source = git+https://github.com/jackpot51/appstream.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = cosmic-store-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cc538f837e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=cosmic-store-git
+pkgver=r64.01eb413
+pkgrel=1
+pkgdesc="WIP COSMIC app store"
+arch=('x86_64' 'aarch64')
+url="https://github.com/pop-os/cosmic-store"
+license=('GPL-3.0-or-later')
+groups=('cosmic')
+depends=('flatpak')
+makedepends=(
+ 'cargo'
+ 'git'
+ 'just'
+)
+checkdepends=()
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/pop-os/cosmic-store.git'
+ 'git+https://github.com/jackpot51/appstream.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ git submodule init
+ git config submodule.appstream.url "$srcdir/appstream"
+ git -c protocol.file.allow=always submodule update
+
+ export CARGO_HOME="$srcdir/cargo-home"
+ export RUSTUP_TOOLCHAIN=stable
+ just vendor
+}
+
+build() {
+ cd "${pkgname%-git}"
+ export CARGO_HOME="$srcdir/cargo-home"
+ export RUSTUP_TOOLCHAIN=stable
+ just build-vendored
+}
+
+package() {
+ cd "${pkgname%-git}"
+ just rootdir="$pkgdir" install
+}