summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2017-09-14 18:09:36 +0200
committerAlad Wenter2017-09-14 18:09:36 +0200
commit5e64cff202cacae2521162cc9a081aea556bd9c6 (patch)
tree315db6f1d3d9e131cc4b1dba1b36f412f6db1f55
parentc2a46539d7a5c5aec5e67b2a5476ee272e82c34d (diff)
downloadaur-5e64cff202cacae2521162cc9a081aea556bd9c6.tar.gz
cottage-git: patch Makefile (LDFLAGS)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4f06e98f4cb..e05df94c8b6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 19:03:02 UTC 2017
+# Thu Sep 14 16:09:34 UTC 2017
pkgbase = cottage-git
pkgdesc = Use howm commands, operators and set configuration values through a UNIX socket.
pkgver = 0.3.r0.g79f4476
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/HarveyHunt/cottage
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
provides = cottage
conflicts = cottage
source = cottage-git::git+https://github.com/HarveyHunt/cottage
+ source = fix-ldflags.patch::https://patch-diff.githubusercontent.com/raw/HarveyHunt/cottage/pull/11.patch
sha256sums = SKIP
+ sha256sums = b8f849db21d230c6fd800c9979e16620970110da2f69b1a646c07399b4481d26
pkgname = cottage-git
diff --git a/PKGBUILD b/PKGBUILD
index d1a9ccfa8751..0ea45b0ac4e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,37 @@
# Maintainer: Alad Wenter <alad@mailbox.org>
pkgname=cottage-git
pkgver=0.3.r0.g79f4476
-pkgrel=1
+pkgrel=2
pkgdesc="Use howm commands, operators and set configuration values through a UNIX socket."
url="https://github.com/HarveyHunt/cottage"
license=('GPL')
arch=('i686' 'x86_64')
+makedepends=('git')
conflicts=('cottage')
provides=('cottage')
-source=("$pkgname::git+https://github.com/HarveyHunt/cottage")
-sha256sums=('SKIP')
+source=("$pkgname::git+https://github.com/HarveyHunt/cottage"
+ 'fix-ldflags.patch::https://patch-diff.githubusercontent.com/raw/HarveyHunt/cottage/pull/11.patch')
+sha256sums=('SKIP'
+ 'b8f849db21d230c6fd800c9979e16620970110da2f69b1a646c07399b4481d26')
+
+prepare() {
+ cd "$pkgname"
+ patch -p1 < "$srcdir"/fix-ldflags.patch
+}
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//; s/-/.r/; s/-/./'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {
- cd "$pkgname"
- make debug
+ cd "$pkgname"
+ make debug
}
package() {
- cd "$pkgname"
- install -Dm755 cottage "$pkgdir/usr/bin/cottage"
+ cd "$pkgname"
+ install -Dm755 cottage "$pkgdir/usr/bin/cottage"
}
# vim:set ts=2 sw=2 et: