summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2017-09-10 20:20:41 +0200
committerAlad Wenter2017-09-10 20:20:41 +0200
commitb5a198c586c324f9fb0b7aeaa99b87f108f9dc9c (patch)
tree31ed465ea68bcd4eebcf9aa028416153ad20118d
parent717eb9543065f7e45d16be7212106a1f1ddcaabe (diff)
downloadaur-b5a198c586c324f9fb0b7aeaa99b87f108f9dc9c.tar.gz
cottage-git: fix pkgver()
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63f22840c9a6..233ab9eb9694 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,17 @@
-# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
-# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
-
+# Maintainer: Alad Wenter <alad@mailbox.org>
pkgname=cottage-git
-pkgver=79f4476
+pkgver=0.3.r0.g79f4476
pkgrel=1
-
pkgdesc="Use howm commands, operators and set configuration values through a UNIX socket."
url="https://github.com/HarveyHunt/cottage"
license=('GPL')
arch=('i686' 'x86_64')
-
-options=('debug')
-source=("$pkgname::git+https://github.com/HarveyHunt/cottage#branch=master")
+source=("$pkgname::git+https://github.com/HarveyHunt/cottage")
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- git rev-parse --short HEAD
+ git describe --long --tags | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {