summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-19 12:21:05 +0200
committerGoliathLabs2020-05-19 12:21:05 +0200
commit3b1967b1769333b8203a6618b4437353b4b6a46e (patch)
tree0fe9c45d5b395f929b13da47431e6e4de00744ab
parent0729d2dd277bf4deead7cf9617d2ba9cfdbafc15 (diff)
downloadaur-3b1967b1769333b8203a6618b4437353b4b6a46e.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--turnserver.service3
-rw-r--r--turnserver.tmpfiles.d3
4 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5103cae8c563..46d5903ac554 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
pkgbase = coturn-git
pkgdesc = Open-source implementation of TURN and STUN server (git)
- pkgver = 4.5.1.1+r50+g24397e8
+ pkgver = 4.5.1.2+r1+g113f138
pkgrel = 1
url = https://github.com/coturn/coturn
- arch = armv7h
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = BSD
makedepends = git
depends = libevent
- depends = sqlite
depends = postgresql-libs
depends = libmariadbclient
- depends = mongo-c-driver
depends = hiredis
+ depends = sqlite
provides = coturn
conflicts = coturn
backup = etc/turnserver/turnserver.conf
- source = git+https://github.com/coturn/coturn
+ source = git+https://github.com/coturn/coturn.git
source = turnserver.service
source = turnserver.sysusers.d
source = turnserver.tmpfiles.d
- sha512sums = SKIP
- sha512sums = 47af7bbf28f8a5fc674b90d1370026405ccb43623f05e47cf915c594e7e35865f4dce64d2b3001bc609a843a54661d1a1172790153f0b8ba9186db48c42b0024
- sha512sums = 32596f741e561c707f69c1ea90adf75c83742906d33c50e1fa5ec0899eeb607d96a48c36fcbb6facb62947beedcace9f6c3fb748c4d67f058bf3f72413766f82
- sha512sums = 9d9ef805d793ee49d23e000a66130f30b6c256943f8004ac43f4712c6ecc7dcf82f24a7e77bb1db041ecf714c869769287ea03fe66f3ab4ad6f8f817d389bca5
+ sha256sums = SKIP
+ sha256sums = 32d0ef62663bcbda0b5c7d324d156ce83605861c3ce63536bc57b5f0e5ba6f5c
+ sha256sums = 92e51ecd664ab53031baa0aeee615fa7c4e73f79c5a3ebc49ac8e0919e4d23fd
+ sha256sums = d765d14ff3a6527498257e4dc9e76231742cd41d8fe658004e171b8937db6a75
pkgname = coturn-git
diff --git a/PKGBUILD b/PKGBUILD
index f4c1adf85817..208da7342598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
-# Maintainer: Jean Lucas <jean@4ray.co>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Jean Lucas <jean@4ray.co>
pkgname=coturn-git
-pkgver=4.5.1.1+r50+g24397e8
+pkgver=4.5.1.2+r1+g113f138
pkgrel=1
pkgdesc='Open-source implementation of TURN and STUN server (git)'
-arch=(armv7h i686 x86_64)
-url=https://github.com/coturn/coturn
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/coturn/coturn"
license=(BSD)
-depends=(libevent sqlite postgresql-libs libmariadbclient mongo-c-driver hiredis)
+depends=(libevent postgresql-libs libmariadbclient hiredis sqlite)
makedepends=(git)
provides=(coturn)
conflicts=(coturn)
backup=(etc/turnserver/turnserver.conf)
-source=(git+$url
+source=(git+https://github.com/coturn/coturn.git
turnserver.service
turnserver.sysusers.d
turnserver.tmpfiles.d)
-sha512sums=('SKIP'
- '47af7bbf28f8a5fc674b90d1370026405ccb43623f05e47cf915c594e7e35865f4dce64d2b3001bc609a843a54661d1a1172790153f0b8ba9186db48c42b0024'
- '32596f741e561c707f69c1ea90adf75c83742906d33c50e1fa5ec0899eeb607d96a48c36fcbb6facb62947beedcace9f6c3fb748c4d67f058bf3f72413766f82'
- '9d9ef805d793ee49d23e000a66130f30b6c256943f8004ac43f4712c6ecc7dcf82f24a7e77bb1db041ecf714c869769287ea03fe66f3ab4ad6f8f817d389bca5')
+sha256sums=('SKIP'
+ '32d0ef62663bcbda0b5c7d324d156ce83605861c3ce63536bc57b5f0e5ba6f5c'
+ '92e51ecd664ab53031baa0aeee615fa7c4e73f79c5a3ebc49ac8e0919e4d23fd'
+ 'd765d14ff3a6527498257e4dc9e76231742cd41d8fe658004e171b8937db6a75')
pkgver() {
- cd coturn
+ cd ${srcdir}/coturn
git describe --tags | sed 's#-#+#g;s#+#+r#'
}
build() {
- cd coturn
+ cd ${srcdir}/coturn
./configure \
--prefix=/usr \
--manprefix=/usr/share \
@@ -37,7 +38,7 @@ build() {
}
check() {
- cd coturn
+ cd ${srcdir}/coturn
make check
}
@@ -46,16 +47,15 @@ package() {
install -Dm 644 turnserver.sysusers.d "$pkgdir"/usr/lib/sysusers.d/turnserver.conf
install -Dm 644 turnserver.tmpfiles.d "$pkgdir"/usr/lib/tmpfiles.d/turnserver.conf
- cd coturn
+ cd ${srcdir}/coturn
make DESTDIR="$pkgdir" install
-
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/coturn
cd "$pkgdir"
# Create needed directories
- mkdir -p {etc/turnserver,var/log/turnserver}
+ install -dm 700 "$pkgdir"/etc/turnserver
# Use Arch-specific directories in config
mv {usr/etc/turnserver.conf.default,etc/turnserver/turnserver.conf}
diff --git a/turnserver.service b/turnserver.service
index 8321256806ce..9fd60a8dad0b 100644
--- a/turnserver.service
+++ b/turnserver.service
@@ -6,6 +6,9 @@ After=network.target
User=turnserver
Type=forking
ExecStart=/usr/bin/turnserver -c /etc/turnserver/turnserver.conf -o -v
+RuntimeDirectory=turnserver
+LogsDirectory=turnserver
+RuntimeDirectoryMode=0700
[Install]
WantedBy=multi-user.target
diff --git a/turnserver.tmpfiles.d b/turnserver.tmpfiles.d
index 7551578948b0..18e4e0b78c5b 100644
--- a/turnserver.tmpfiles.d
+++ b/turnserver.tmpfiles.d
@@ -1,3 +1,2 @@
d /etc/turnserver 0700 turnserver turnserver
-z /etc/turnserver/turnserver.conf 0600 turnserver turnserver
-d /run/turnserver 0700 turnserver turnserver
+Z /etc/turnserver/turnserver.conf 0600 turnserver turnserver