summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Østergaard2015-06-19 21:14:57 +0200
committerNick Østergaard2015-06-19 21:14:57 +0200
commita8ecd411b556c6de7de37a66cf3adc4000204f8c (patch)
tree0848268a1f1341a2f6a8522c5da7a11d8e798cdc
downloadaur-a8ecd411b556c6de7de37a66cf3adc4000204f8c.tar.gz
Initial commit of couchapp-git
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0d0e62e8e86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = couchapp-git
+ pkgdesc = A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly.
+ pkgver = 20140302
+ pkgrel = 1
+ url = http://github.com/couchapp/couchapp/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = setuptools
+ depends = python2
+ depends = python2-restkit
+ depends = python2-watchdog
+ provides = couchapp
+
+pkgname = couchapp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74d9c6b1cfda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Nick Østergaar <oe.nick at gmail dot com>
+# Contributor: Moritz Heidkamp <moritz@twoticketsplease.de>
+# Contributor: Sebastian Sauer <info@dynpages.de>
+
+pkgname=couchapp-git
+pkgver=20140302
+pkgrel=1
+pkgdesc="A set of helpers and a jQuery plugin that conspire to get you up and running on CouchDB quickly and correctly."
+arch=('i686' 'x86_64')
+url="http://github.com/couchapp/couchapp/"
+license=('APACHE')
+depends=('python2' 'python2-restkit' 'python2-watchdog')
+makedepends=('git' 'setuptools')
+provides=(couchapp)
+
+_gitroot="git://github.com/couchapp/couchapp.git"
+_gitname="couchapp"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py install --root "$pkgdir/"
+}