summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitalii Kuzhdin2025-03-08 12:06:42 +0100
committerVitalii Kuzhdin2025-03-08 12:06:42 +0100
commit68f7cfe5640bbb612570638a65d45d69043a0671 (patch)
tree21b4c67641f54478d3a70d9a6673c4a2698d0eb9
downloadaur-68f7cfe5640bbb612570638a65d45d69043a0671.tar.gz
Initial build (0.1.9)
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD24
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3c13634551c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = countryfetch-bin
+ pkgdesc = A neofetch-like tool for fetching information about your country
+ pkgver = 0.1.9
+ pkgrel = 1
+ url = https://github.com/nik-rev/countryfetch
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ depends = glibc
+ provides = countryfetch
+ conflicts = countryfetch
+ source_x86_64 = countryfetch-0.1.9-x86_64.tar.xz::https://github.com/nik-rev/countryfetch/releases/download/v0.1.9/countryfetch-x86_64-unknown-linux-gnu.tar.xz
+ sha256sums_x86_64 = 0ee0108c51baadcb2f6dd187a49405918f9037764114b45f30484942c11a611c
+
+pkgname = countryfetch-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218cc907c9ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..ecd9786cadea
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[countryfetch-bin]
+source = "github"
+github = "nik-rev/countryfetch"
+use_latest_release = true
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dad2b3ac381
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vitalii Kuzhdin <vitaliikuzhdin@gmail.com>
+
+_pkgname="countryfetch"
+pkgname="${_pkgname}-bin"
+pkgver=0.1.9
+pkgrel=1
+pkgdesc="A neofetch-like tool for fetching information about your country"
+arch=('x86_64')
+url="https://github.com/nik-rev/${_pkgname}"
+license=('MIT')
+depends=('gcc-libs' 'glibc')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+_pkgsrc="${_pkgname}-${pkgver}"
+source_x86_64=("${_pkgsrc}-x86_64.tar.xz::${url}/releases/download/v${pkgver}/${_pkgname}-x86_64-unknown-linux-gnu.tar.xz")
+sha256sums_x86_64=('0ee0108c51baadcb2f6dd187a49405918f9037764114b45f30484942c11a611c')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${CARCH}-unknown-linux-gnu"
+ install -vDm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -vDm644 "CHANGELOG.md" "${pkgdir}/usr/share/doc/${_pkgname}/CHANGELOG.md"
+ install -vDm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -vDm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}