summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrunnytu2017-08-16 20:51:22 +0200
committerrunnytu2017-08-16 20:51:22 +0200
commit1b7486358bc43e3a16b9378f94a8c0dbb928faf3 (patch)
tree8cf9accb76994a583e33e76c280023a983a36170
parent52f6f875f09770c9978158b13722e442c33dcb76 (diff)
downloadaur-1b7486358bc43e3a16b9378f94a8c0dbb928faf3.tar.gz
Tiddy up PKGBUILD
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41dcca273f3e..b5eebf14c801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,10 +26,12 @@ install=${pkgname}.install
source=(http://downloads.sourceforge.net/project/courier/authlib/${pkgver}/${pkgname}-${pkgver}.tar.bz2
courier-authlib.tmpfiles
authdaemond.service)
-sha512sums=('5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b' '5047fea9990cd2cd415e11c81fbd8ff83b70dadf0fc178b2398b2c9930843a4669abb3c6801f2953c1ebfdae73c1f82d0ee8c24e900f3876ee6b3aa689363b62' '2168a3d2f92bbc4c24ba80030236dd39a871ccd0f945ea9481518356f6ddfeec3661f161cd6a65d852bce6d9b089d7fa4860337615b9157199aaef336c58d268')
+sha512sums=('5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b'
+'5047fea9990cd2cd415e11c81fbd8ff83b70dadf0fc178b2398b2c9930843a4669abb3c6801f2953c1ebfdae73c1f82d0ee8c24e900f3876ee6b3aa689363b62'
+'2168a3d2f92bbc4c24ba80030236dd39a871ccd0f945ea9481518356f6ddfeec3661f161cd6a65d852bce6d9b089d7fa4860337615b9157199aaef336c58d268')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \
--sbindir=/usr/bin \
--sysconfdir=/etc \
@@ -54,21 +56,21 @@ build() {
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR=${pkgdir} install
+ make DESTDIR="${pkgdir}" install
- for distfile in ${pkgdir}/etc/authlib/*.dist; do
+ for _distfile in "${pkgdir}/etc/authlib/*.dist"; do
# change ownership - this is usually done by the Makefile where it is assumed the user & group already exist
- chown 72:72 ${distfile}
+ chown 72:72 "${_distfile}"
# remove the .dist suffix - mimics the install-configure step of a standard Courier installation
- mv ${distfile} ${pkgdir}/etc/authlib/`basename ${distfile} .dist`
+ mv "${_distfile}" "${pkgdir}/etc/authlib/"`basename "${_distfile}" .dist`
done
# copy the .schema; mostly refered to as courier.schema -> rename it
- install -Dm 444 authldap.schema ${pkgdir}/etc/openldap/schema/courier.schema
+ install -Dm 444 authldap.schema "${pkgdir}/etc/openldap/schema/courier.schema"
- chown 72:72 ${pkgdir}/usr/lib/courier-authlib
+ chown 72:72 "${pkgdir}/usr/lib/courier-authlib"
# Install service file
install -Dm 644 "${srcdir}/authdaemond.service" "${pkgdir}/usr/lib/systemd/system/authdaemond.service"