summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeil Romig2021-08-29 07:54:16 +0100
committerNeil Romig2021-08-29 07:54:16 +0100
commit1f68475aa847ef16bbe61d39f393fcc3136382ca (patch)
tree033f443de0cbf27c13fbe3a431fcc79f471dcc67
parent21b3b7471887265bfbf490ab8551a8c5e7b2ea44 (diff)
downloadaur-1f68475aa847ef16bbe61d39f393fcc3136382ca.tar.gz
added post install process
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--courier-pythonfilter.install9
3 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44bd76b868bb..49d658b9706e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = courier-pythonfilter
pkgdesc = pythonfilter is a collection of useful filters for the Courier MTA, and a framework for developing new filters in Python.
pkgver = 3.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.org/project/courier-pythonfilter
+ install = courier-pythonfilter.install
arch = any
license = GPL
depends = python3
@@ -10,6 +11,8 @@ pkgbase = courier-pythonfilter
backup = etc/pythonfilter.conf
backup = etc/pythonfilter-modules.conf
source = https://bitbucket.org/gordonmessmer/courier-pythonfilter/get/fdf2f466e757.zip
+ source = courier-pythonfilter.install
sha1sums = c885c66ce0e5876873da6575419d116ca1d7bdda
+ sha1sums = 678bd5e4a3da90e267d359cbe04572cf976c6a07
pkgname = courier-pythonfilter
diff --git a/PKGBUILD b/PKGBUILD
index 67ca13bc583d..d0a808be2ace 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=courier-pythonfilter
pkgver=3.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="pythonfilter is a collection of useful filters for the Courier MTA, and a framework for developing new filters in Python."
arch=(any)
url="https://pypi.org/project/courier-pythonfilter"
@@ -15,8 +15,11 @@ conflicts=()
replaces=()
backup=('etc/pythonfilter.conf' 'etc/pythonfilter-modules.conf')
options=()
-source=(https://bitbucket.org/gordonmessmer/courier-pythonfilter/get/fdf2f466e757.zip)
-sha1sums=('c885c66ce0e5876873da6575419d116ca1d7bdda')
+install=courier-pythonfilter.install
+source=(https://bitbucket.org/gordonmessmer/courier-pythonfilter/get/fdf2f466e757.zip
+ courier-pythonfilter.install)
+sha1sums=('c885c66ce0e5876873da6575419d116ca1d7bdda'
+ '678bd5e4a3da90e267d359cbe04572cf976c6a07')
package() {
cd "$srcdir/gordonmessmer-courier-pythonfilter-fdf2f466e757"
diff --git a/courier-pythonfilter.install b/courier-pythonfilter.install
new file mode 100644
index 000000000000..3b8716ea63db
--- /dev/null
+++ b/courier-pythonfilter.install
@@ -0,0 +1,9 @@
+post_install() {
+ ln -s /usr/bin/pythonfilter /usr/lib/filters/pythonfilter
+ mkdir /var/lib/pythonfilter
+ chown courier:courier /var/lib/pythonfilter
+}
+
+post_remove() {
+ rm -rf /usr/lib/filters/pythonfilter /var/lib/pythonfilter
+}