summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexchain Tong2016-02-21 16:06:54 +0800
committerHexchain Tong2016-02-21 16:06:54 +0800
commit81e0a1999f2a1b3b2735f00fd3176f55d0419a16 (patch)
treed160552fe60cf6ad63ca8c97e5c4ae2fafb241ae
parent2a5be237595d0d66601f586912d562881725b541 (diff)
downloadaur-81e0a1999f2a1b3b2735f00fd3176f55d0419a16.tar.gz
upgpkg: coursera-dl-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d148da854d7..d4ff72e1df01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 08:06:44 UTC 2016
pkgbase = coursera-dl-git
pkgdesc = Script for downloading Coursera.org videos and naming them
- pkgver = 823.45bdcac
+ pkgver = 0.5.2.r0.g38f190a
pkgrel = 1
- url = https://github.com/coursera-dl/coursera/
+ url = https://github.com/coursera-dl/coursera-dl/
arch = any
- license = GPL
+ license = LGPL3
makedepends = git
depends = python
+ depends = python-pyasn1
depends = python-beautifulsoup4
depends = python-distribute
depends = python-requests
depends = python-six
- optdepends = python-html5lib: recommended for parsing pages
- source = git://github.com/coursera-dl/coursera.git
+ provides = coursera-dl
+ conflicts = coursera-dl
+ source = git://github.com/coursera-dl/coursera-dl.git
sha256sums = SKIP
pkgname = coursera-dl-git
diff --git a/PKGBUILD b/PKGBUILD
index 902ce7a1463e..274bf21d2db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,28 @@
# Maintainer: Hexchain Tong <i@hexchain.org>
pkgname=coursera-dl-git
-_gitname=coursera
-pkgver=823.45bdcac
+_gitname=${pkgname/-git/}
+pkgver=0.5.2.r0.g38f190a
pkgrel=1
pkgdesc="Script for downloading Coursera.org videos and naming them"
arch=('any')
-url="https://github.com/coursera-dl/coursera/"
-license=('GPL')
-depends=('python' 'python-beautifulsoup4' 'python-distribute' 'python-requests' 'python-six')
-optdepends=('python-html5lib: recommended for parsing pages')
+url="https://github.com/coursera-dl/coursera-dl/"
+license=('LGPL3')
+depends=('python' 'python-pyasn1' 'python-beautifulsoup4' 'python-distribute' 'python-requests' 'python-six')
makedepends=('git')
+provides=('coursera-dl')
+conflicts=('coursera-dl')
source=("git://github.com/coursera-dl/$_gitname.git")
sha256sums=('SKIP')
pkgver() {
cd $_gitname
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd $_gitname
- install -Dm755 ${pkgname%-*} "$pkgdir/usr/bin/${pkgname%-*}"
- install -dm755 $_gitname "$pkgdir/usr/lib/python3.5/site-packages/$_gitname"
- install -cm644 $_gitname/*.py "$pkgdir/usr/lib/python3.5/site-packages/$_gitname/"
+ cd "$srcdir/$_gitname"
+ python ./setup.py install -O1 --root="$pkgdir"
+ install -Dm755 coursera-dl "$pkgdir/usr/bin/coursera-dl"
}
# vim: set ts=2 sw=2 et: