aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartynas Mickevičius2018-01-02 14:32:25 +0700
committerMartynas Mickevičius2018-01-02 14:32:25 +0700
commite25f037f997821d8cca172d58ef2e34a62d563d9 (patch)
treed2806022721f85adb4b3a8173dbc11d777f5b213
downloadaur-e25f037f997821d8cca172d58ef2e34a62d563d9.tar.gz
And hence the coursier has arrived to the ArchLinux community
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--.travis.yml15
-rw-r--r--PKGBUILD19
-rw-r--r--README.md19
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a4d7c8d0ca5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = coursier
+ pkgdesc = Pure Scala Artifact Fetching
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://get-coursier.io
+ arch = any
+ license = Apache
+ depends = java-environment
+ depends = bash
+ noextract = coursier
+ source = https://github.com/coursier/coursier/raw/v1.0.0/coursier
+ sha256sums = 32cf24bbd4221f1d36129e326baeff908eb84ee99dd686ae19a3e339ee63c704
+
+pkgname = coursier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f4da90b2850
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.pkg.tar
+/src
+/pkg
+coursier
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..25df271d7d36
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,15 @@
+sudo: required
+
+arch:
+ packages:
+ - namcap
+ script:
+ - namcap PKGBUILD
+ - makepkg
+ - namcap coursier-*
+ - pacman -Qip coursier-*
+ - pacman -Qlp coursier-*
+
+
+script:
+ - "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8ce11397c1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Martynas Mickevičius <self at 2m dot lt>
+_version=1.0.0
+
+pkgname=coursier
+pkgver="$_version"
+pkgrel=1
+pkgdesc="Pure Scala Artifact Fetching"
+arch=('any')
+url="http://get-coursier.io"
+license=('Apache')
+depends=('java-environment' 'bash')
+
+source=("https://github.com/coursier/coursier/raw/v$pkgver/coursier")
+sha256sums=('32cf24bbd4221f1d36129e326baeff908eb84ee99dd686ae19a3e339ee63c704')
+noextract=('coursier')
+
+package() {
+ install -D -m755 "coursier" "${pkgdir}/usr/bin/coursier"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..8ff9bea456d8
--- /dev/null
+++ b/README.md
@@ -0,0 +1,19 @@
+# Package build description for [coursier](http://get-coursier.io/)
+
+This repository holds instructions for building an Arch Linux package for coursier.
+
+## Pushing to AUR
+
+First generate `.SRCINFO` by:
+
+```
+pacaur -S pkgbuild-introspection-git
+gitmksrcinfo
+```
+
+Then push to AUR git repository by:
+
+```
+git remote add aur ssh://aur@aur.archlinux.org/coursier.git
+git push aur
+```