aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartynas Mickevičius2019-01-17 10:48:05 +0700
committerMartynas Mickevičius2019-01-17 10:48:05 +0700
commite54f501d23aea01a5385a5e92241489452b6cdd2 (patch)
treea0480cfb652be10e2feb76c7e31fe1992669c5f9
parentdb64014edc340a5c39af92337f8b552e4c3d1a2e (diff)
downloadaur-e54f501d23aea01a5385a5e92241489452b6cdd2.tar.gz
Give unique name to the builder executable
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d9617af814e..8e617d308996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = coursier
pkgdesc = Pure Scala Artifact Fetching
pkgver = 1.1.0_M10
- pkgrel = 1
+ pkgrel = 2
url = http://get-coursier.io
arch = any
license = Apache
depends = java-runtime-headless>=8
depends = bash
- noextract = coursier
- source = https://github.com/coursier/coursier/raw/v1.1.0-M10/coursier
+ noextract = builder-1.1.0_M10
+ source = builder-1.1.0_M10::https://github.com/coursier/coursier/raw/v1.1.0-M10/coursier
sha256sums = c817d0d9860e2abc7420d6bde1800fb7d74dc4612d9a1480aca0b67dc2013892
pkgname = coursier
diff --git a/PKGBUILD b/PKGBUILD
index 40af0d2187bf..cd985f574cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@ _version=1.1.0-M10
pkgname=coursier
pkgver="${_version/-/_}"
-pkgrel=1
+pkgrel=2
pkgdesc="Pure Scala Artifact Fetching"
arch=('any')
url="http://get-coursier.io"
license=('Apache')
depends=('java-runtime-headless>=8' 'bash')
-source=("https://github.com/coursier/coursier/raw/v${_version}/coursier")
+source=("builder-$pkgver::https://github.com/coursier/coursier/raw/v${_version}/coursier")
sha256sums=('c817d0d9860e2abc7420d6bde1800fb7d74dc4612d9a1480aca0b67dc2013892')
-noextract=('coursier')
+noextract=("builder-$pkgver")
build() {
cd "${srcdir}"
mkdir -p cache bin
export COURSIER_CACHE="${srcdir}/cache"
- sh ./coursier bootstrap \
+ sh ./builder-$pkgver bootstrap \
--intransitive "io.get-coursier::coursier-cli:${_version}" \
--classifier standalone \
--artifact-type jar \