summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-08-31 17:18:38 +0200
committeramesgen2020-08-31 17:18:38 +0200
commit5ea0d72b1e41927e861d1034841401cda24d75f4 (patch)
tree7238b8bcc3cc128f699b745c05bacfa9176ca793
downloadaur-5ea0d72b1e41927e861d1034841401cda24d75f4.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..decce9488cff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = coursier-native
+ pkgdesc = Pure Scala Artifact Fetching (native-image edition)
+ pkgver = 2.0.0_RC6_24
+ pkgrel = 1
+ url = http://get-coursier.io
+ arch = x86_64
+ license = Apache
+ depends = gcc-libs
+ depends = zlib
+ provides = coursier
+ conflicts = coursier
+ source = coursier-2.0.0_RC6_24::https://github.com/coursier/coursier/releases/download/v2.0.0-RC6-24/cs-x86_64-pc-linux
+ sha256sums = c598326e21b57c1dcaaefa797dbbfe47724922cd7649e86a43c8acab3743aeb0
+
+pkgname = coursier-native
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2098409f1eae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: amesgen <amesgen AT amesgen DOT de>
+
+pkgname=coursier-native
+_pkgver=2.0.0-RC6-24
+pkgver="${_pkgver//-/_}"
+pkgrel=1
+pkgdesc="Pure Scala Artifact Fetching (native-image edition)"
+arch=("x86_64")
+url="http://get-coursier.io"
+license=("Apache")
+depends=("gcc-libs" "zlib")
+provides=("coursier")
+conflicts=("coursier")
+source=("coursier-$pkgver::https://github.com/coursier/coursier/releases/download/v$_pkgver/cs-x86_64-pc-linux")
+sha256sums=('c598326e21b57c1dcaaefa797dbbfe47724922cd7649e86a43c8acab3743aeb0')
+
+package() {
+ install -Dm755 "coursier-$pkgver" "$pkgdir/usr/bin/coursier"
+}