summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-09 12:55:08 +0200
committerValHue2015-06-09 12:55:08 +0200
commit759b956396c9c584279d1c5bf81e030e585941d3 (patch)
treea83d2998ff2b4320258c9d7d23f2d82664756e21
downloadaur-759b956396c9c584279d1c5bf81e030e585941d3.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--cover-thumbnailer.install19
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e89cb54db75c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cover-thumbnailer
+ pkgdesc = A Python script which displays music album covers in nautilus, preview of pictures which are in a folder and more.
+ pkgver = 0.8.3
+ pkgrel = 4
+ url = https://launchpad.net/cover-thumbnailer
+ install = cover-thumbnailer.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gettext
+ depends = python2-pillow
+ depends = python2-gconf
+ provides = cover-thumbnailer
+ source = https://launchpad.net/cover-thumbnailer/v0.8/v0.8.3/+download/cover-thumbnailer_0.8.3_src.tar.gz
+ sha256sums = c0d5213743cb251428b9998d7838d6d6e64bb4bb9ccd3a21ffebb3fc21b688c4
+
+pkgname = cover-thumbnailer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fc129c38101
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: Moritz Lüdecke <ritze at skweez dot net>
+# Contributor: boenki <boenki at gmx dot de>
+
+pkgname="cover-thumbnailer"
+pkgver="0.8.3"
+pkgrel="4"
+pkgdesc="A Python script which displays music album covers in nautilus, preview of pictures which are in a folder and more."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/cover-thumbnailer"
+license=('GPL3')
+depends=('python2-pillow' 'python2-gconf')
+makedepends=('gettext')
+provides=("${pkgname}")
+source=("https://launchpad.net/${pkgname}/v0.8/v${pkgver}/+download/${pkgname}_${pkgver}_src.tar.gz")
+sha256sums=('c0d5213743cb251428b9998d7838d6d6e64bb4bb9ccd3a21ffebb3fc21b688c4')
+
+install="${pkgname}.install"
+
+build() {
+ cd "${srcdir}/${pkgname}_${pkgver}_src"
+
+ ### Python2 Fix ###
+ sed -i "s|#!/usr/bin/python|#!/usr/bin/python2|g" ${pkgname}{,-gui}.py
+
+ ### Python2-pillow (PIL) Fix ###
+ sed -i "/import Image/i\from PIL import Image" ${pkgname}.py
+ sed -i "s|import Image, urllib|import urllib|g" ${pkgname}.py
+ sed -i "s|!=|is not|g" ${pkgname}.py
+
+ ### Thumbnailers cache Fix (Gnome 3.12) ###
+ sed -i "s|.thumbnails|.cache/thumbnails|g" ${pkgname}-gui.py
+}
+
+package() {
+ cd "${srcdir}/${pkgname}_${pkgver}_src"
+ ./install.sh -p ${pkgdir}
+}
+
+# vim:set ts=4 sw=2 ft=sh et:
diff --git a/cover-thumbnailer.install b/cover-thumbnailer.install
new file mode 100644
index 000000000000..eea40442e347
--- /dev/null
+++ b/cover-thumbnailer.install
@@ -0,0 +1,19 @@
+# cover-thumbnailer.install
+
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ echo ""
+ echo " Do not forget to delete the cache of thumbnails:"
+ echo " rm rf ~/.thumbnails"
+ echo " rm rf ~/.cache/thumbnails"
+ echo ""
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_install $1
+}