summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorC. Dominik Bódi2016-10-17 19:17:28 +0200
committerC. Dominik Bódi2016-10-17 19:17:28 +0200
commit79b6aeae3c1d1468732e8f9721e95eadc9b1b794 (patch)
tree6c430862b2cf683a2a5ef885ac8ca2360f19c1be
parent183a5b0e2d6bf288bc05ffffe1cd1d2871171754 (diff)
downloadaur-79b6aeae3c1d1468732e8f9721e95eadc9b1b794.tar.gz
* updated to upstream version 0.81
* added depends to ncurses and ncurses5-compat-libs * remove '--as-needed' from LDFLAGS, build fails otherwise
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12295f0ead94..eee30c5aba59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Oct 17 17:15:58 UTC 2016
pkgbase = cowdancer
pkgdesc = Copy-on-write wrapper for pbuilder
- pkgver = 0.80
+ pkgver = 0.81
pkgrel = 1
url = https://packages.debian.org/sid/cowdancer
arch = i686
arch = x86_64
license = GPL
depends = pbuilder-ubuntu
+ depends = ncurses
+ depends = ncurses5-compat-libs
optdepends = qemu: if you want to use qemubuilder
optdepends = bash-completion: bash autocomplete support
- source = http://httpredir.debian.org/debian/pool/main/c/cowdancer/cowdancer_0.80.tar.xz
- sha256sums = a110f3d9690a29762ab469364cfddd75f3688ff3d12086e625e92fa26948f289
+ source = http://httpredir.debian.org/debian/pool/main/c/cowdancer/cowdancer_0.81.tar.xz
+ sha256sums = 0a9f344f4271a8e4eef7a087ac6a28a8741b9b78e73669626373b7b729776ad4
pkgname = cowdancer
diff --git a/PKGBUILD b/PKGBUILD
index f141a9fa918f..86cc724bc983 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,26 @@
# Contributor: JD Horelick <jdhore1@gmail.com>
# Contributor: Alad Wenter <alad@linuxbbq.org>
pkgname=cowdancer
-pkgver=0.80
+pkgver=0.81
pkgrel=1
pkgdesc="Copy-on-write wrapper for pbuilder"
arch=('i686' 'x86_64')
url="https://packages.debian.org/sid/cowdancer"
license=('GPL')
-depends=('pbuilder-ubuntu')
+depends=('pbuilder-ubuntu'
+ 'ncurses'
+ 'ncurses5-compat-libs')
optdepends=('qemu: if you want to use qemubuilder'
'bash-completion: bash autocomplete support')
source=(http://httpredir.debian.org/debian/pool/main/c/$pkgname/${pkgname}_${pkgver}.tar.xz)
-sha256sums=('a110f3d9690a29762ab469364cfddd75f3688ff3d12086e625e92fa26948f289')
+sha256sums=('0a9f344f4271a8e4eef7a087ac6a28a8741b9b78e73669626373b7b729776ad4')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # cow-shell fails to compile if linker is called with '--as-needed'
+ # therefore we strip that flag from LDFLAGS from makepkg.conf
+ export LDFLAGS=$(echo $LDFLAGS | sed 's/,--as-needed//g')
make
}