summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgeigi2017-10-22 17:55:22 +0200
committergeigi2017-10-22 17:55:22 +0200
commit9f269f7741e3f6bea9b5a9eb3d8e253633519a67 (patch)
tree0c0c65e4c98ddbd08c1d88b1b3c35e48e8b7c825
downloadaur-9f269f7741e3f6bea9b5a9eb3d8e253633519a67.tar.gz
First release
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..881b9b117caf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = cozy-audiobooks
+ pkgdesc = A modern audio book player for Linux using GTK+ 3.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/geigi/cozy
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = appstream-glib
+ depends = desktop-file-utils
+ depends = gobject-introspection
+ depends = gst-python
+ depends = gstreamer
+ depends = gtk3
+ depends = python-dbus
+ depends = python-gobject
+ depends = python-mutagen
+ provides = cozy
+ conflicts = cozy
+ source = https://github.com/geigi/cozy/archive/0.2.2.zip
+ sha256sums = SKIP
+
+pkgname = cozy-audiobooks
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc9028b62ecb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beefe697719f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Julian Gwywitz <aur@geigi.de>+
+
+pkgname=cozy-audiobooks
+_gitname=cozy
+pkgdesc=' A modern audio book player for Linux using GTK+ 3.'
+pkgver=0.2.2
+pkgrel=1
+url='https://github.com/geigi/cozy'
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('meson' 'ninja')
+depends=(
+ 'appstream-glib' 'desktop-file-utils' 'gobject-introspection' 'gst-python'
+ 'gstreamer' 'gtk3' 'python-dbus' 'python-gobject' 'python-mutagen'
+)
+conflicts=("${_gitname}")
+provides=("${_gitname}")
+source=(
+ "https://github.com/geigi/cozy/archive/${pkgver}.zip"
+
+)
+sha256sums=(
+ 'SKIP'
+)
+
+build() {
+ cd "cozy-${pkgver}"
+ meson \
+ --buildtype='release' \
+ --prefix='/usr' \
+ build
+ ninja -C build
+}
+
+package() {
+ cd "cozy-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+} \ No newline at end of file