summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Menzhinsky2019-07-30 10:11:35 +0300
committerAlexander Menzhinsky2019-07-30 10:11:35 +0300
commit540a77cd8f5085aa0ddd564641d702bfa827166b (patch)
treee641131e25869398427f3517e382ac7e2d27812e
downloadaur-540a77cd8f5085aa0ddd564641d702bfa827166b.tar.gz
Init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--README.md5
-rw-r--r--dkms.conf9
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d64d2347f9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cp210x
+ pkgdesc = Silicon Labs CP210x RS232 serial adaptor driver
+ pkgver = 2019.7.12
+ pkgrel = 1
+ url = https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
+ arch = any
+ license = GPL
+ makedepends = linux-headers
+ depends = linux
+ source = https://www.silabs.com/documents/login/software/Linux_3.x.x_4.x.x_VCP_Driver_Source.zip
+ source = dkms.conf
+ sha256sums = 7d624cd66ee610fd9c6598793534ed593ac1309b3d3b3699c101d921ad9ccd7c
+ sha256sums = 62da72a3f8f9566326168a759cb5cc54b8c39aeb6594e1b4229774868c7eb3d2
+
+pkgname = cp210x
+
+pkgname = cp210x-dkms
+ depends = dkms
+ provides = cp210x=2019.7.12-1
+ conflicts = cp210x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..110b0d25907a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Alexander Menzhinsky <amenzhinsky@gmail.com>
+
+pkgbase=cp210x
+pkgname=(cp210x cp210x-dkms)
+pkgver=2019.7.12
+pkgrel=1
+pkgdesc='Silicon Labs CP210x RS232 serial adaptor driver'
+url='https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers'
+arch=('any')
+license=('GPL')
+depends=('linux')
+makedepends=('linux-headers')
+_extramodules=extramodules-ARCH
+source=("https://www.silabs.com/documents/login/software/Linux_3.x.x_4.x.x_VCP_Driver_Source.zip"
+ dkms.conf)
+sha256sums=('7d624cd66ee610fd9c6598793534ed593ac1309b3d3b3699c101d921ad9ccd7c'
+ '62da72a3f8f9566326168a759cb5cc54b8c39aeb6594e1b4229774868c7eb3d2')
+
+build() {
+ make KVERSION="$(cat /usr/lib/modules/$_extramodules/version)"
+}
+
+package_cp210x() {
+ cd $pkgbase-$pkgver
+ install -Dt "$pkgdir/usr/lib/modules/$_extramodules" -m644 *.ko
+ find "$pkgdir" -name '*.ko' -exec xz {} +
+
+ echo cp210x | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/cp210x.conf"
+
+ mkdir -p "$pkgdir/usr/share/cp210x"
+}
+
+package_cp210x-dkms() {
+ depends=(dkms)
+ provides=("cp210x=$pkgver-$pkgrel")
+ conflicts=(cp210x)
+
+ install -Dt "$pkgdir/usr/src/$pkgbase-$pkgver" -m644 Makefile cp210x.c dkms.conf
+
+ echo cp210x | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/cp210x.conf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..f612a745a589
--- /dev/null
+++ b/README.md
@@ -0,0 +1,5 @@
+# cp210x
+
+Silicon Labs CP210x USB to UART Bridge VCP kernel modules for Arch Linux.
+
+
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..5723f5bdb79b
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,9 @@
+PACKAGE_NAME="cp210x"
+PACKAGE_VERSION="#MODULE_VERSION#"
+AUTOINSTALL="yes"
+
+MAKE[0]="make KVERSION=$kernelver"
+CLEAN="make clean"
+
+BUILT_MODULE_NAME[0]="cp210x"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/cp210x"