summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2016-03-20 13:49:52 -0400
committerEric Berquist2016-03-20 13:49:52 -0400
commit31acdcadcda03b93bbd2f98764d373fc5bb7c304 (patch)
treeab39b75b6f122fb1a87b5dbe49ab1c40e9bf31bc
downloadaur-31acdcadcda03b93bbd2f98764d373fc5bb7c304.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD20
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..209d1caea0ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Mar 20 17:48:26 UTC 2016
+pkgbase = cp2k-bin
+ pkgdesc = A quantum chemistry and solid state physics software package for atomistic simulations of solid state, liquid, molecular, periodic, material, crystal, and biological systems. (precompiled, OpenMP)
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.cp2k.org
+ arch = x86_64
+ license = GPL2
+ provides = cp2k
+ conflicts = cp2k
+ source = cp2k::https://sourceforge.net/projects/cp2k/files/precompiled/cp2k-3.0-Linux-x86_64.ssmp/download
+ md5sums = 1b1d72465475bfb5a9b0e009dd129425
+
+pkgname = cp2k-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..862ae846bff6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+cp2k
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d7ea789bcdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+_name=cp2k
+pkgname=${_name}-bin
+pkgver=3.0
+pkgrel=1
+pkgdesc="A quantum chemistry and solid state physics software package for atomistic simulations of solid state, liquid, molecular, periodic, material, crystal, and biological systems. (precompiled, OpenMP)"
+arch=("x86_64")
+url="https://www.cp2k.org"
+license=("GPL2")
+provides=("${_name}")
+conflicts=("${_name}")
+source=("${_name}::https://sourceforge.net/projects/${_name}/files/precompiled/${_name}-${pkgver}-Linux-x86_64.ssmp/download")
+md5sums=('1b1d72465475bfb5a9b0e009dd129425')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm755 "${_name}" "${pkgdir}"/usr/bin/"${_name}"
+}