summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Cs2024-02-06 01:35:10 +0100
committerBence Cs2024-02-06 01:35:10 +0100
commit25047fd83dfc7982ddd4ba1119e6e462732e30bc (patch)
tree37d98cd106f6a0bbce07e5bd98c00e108d436e1c
downloadaur-25047fd83dfc7982ddd4ba1119e6e462732e30bc.tar.gz
CPAN2AUR2Git v0.0.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af8114500060
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = cpan2aur2git
+ pkgdesc = CPAN2AUR wrapper
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/bence98/cpan2aur2git
+ arch = any
+ license = GPL-3.0-or-later
+ options = !emptydirs
+ source = cpan2aur2git-0.0.1::git+https://github.com/bence98/cpan2aur2git.git#tag=v0.0.1
+ md5sums = SKIP
+
+pkgname = cpan2aur2git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33fada79dfcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Bence Cs <bence98 at sch bme hu>
+
+pkgname='cpan2aur2git'
+pkgver='0.0.1'
+pkgrel='1'
+pkgdesc="CPAN2AUR wrapper"
+arch=('any')
+url='https://github.com/bence98/cpan2aur2git'
+license=('GPL-3.0-or-later')
+options=('!emptydirs')
+depends=()
+source=("$pkgname-$pkgver::git+https://github.com/bence98/cpan2aur2git.git#tag=v0.0.1")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}