summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Cs2024-02-07 09:13:11 +0100
committerBence Cs2024-02-07 09:13:11 +0100
commit7a6f978ded07b3ec547cc211095c569713dac140 (patch)
tree5f288ff0befb2e43190d8e0b8acdcdf08e9bc594
parent25047fd83dfc7982ddd4ba1119e6e462732e30bc (diff)
downloadaur-7a6f978ded07b3ec547cc211095c569713dac140.tar.gz
Fix deps
Thanks @micwoj92 !
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33fada79dfcf..7f15f47c68c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
pkgname='cpan2aur2git'
pkgver='0.0.1'
-pkgrel='1'
+pkgrel='2'
pkgdesc="CPAN2AUR wrapper"
arch=('any')
-url='https://github.com/bence98/cpan2aur2git'
+url="https://github.com/bence98/${pkgname}"
license=('GPL-3.0-or-later')
options=('!emptydirs')
-depends=()
-source=("$pkgname-$pkgver::git+https://github.com/bence98/cpan2aur2git.git#tag=v0.0.1")
+depends=('perl-cpanplus-dist-arch' 'python-requests')
+optdepends=('postfix: for receiving mail for automatic processing with cpanbot-mail')
+source=("git+${url}#tag=v${pkgver}")
md5sums=('SKIP')
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
}