summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthacoon2018-12-04 21:28:22 +0100
committerthacoon2018-12-04 21:28:22 +0100
commitec0778c11e5aca09faeb3c5a3eaace9e02cb286b (patch)
tree2bd734f907446c7731f9680bbd0fa3dcbb9bda3b
parentf4d1291218dd168b75c72295799eafda97419573 (diff)
downloadaur-ec0778c11e5aca09faeb3c5a3eaace9e02cb286b.tar.gz
Use tags/releases
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1594d563a60..dbd4af6733d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,10 @@ pkgbase = cpass
url = https://gitlab.com/thacoon/cpass.git
arch = x86_64
license = MIT
- makedepends = git
depends = rust
depends = cargo
- depends = git
- source = git+https://gitlab.com/thacoon/cpass.git
+ depends = gcc-libs
+ source = git+https://gitlab.com/thacoon/cpass.git?ref=v0.0.1
sha256sums = SKIP
pkgname = cpass
diff --git a/PKGBUILD b/PKGBUILD
index 91cd2f461bea..dfae1aa026f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,8 @@ pkgdesc="A terminal password manager written in Rust."
arch=("x86_64")
url="https://gitlab.com/thacoon/cpass.git"
license=('MIT')
-depends=('rust' 'cargo' 'git')
-makedepends=('git')
-source=("git+https://gitlab.com/thacoon/cpass.git")
+depends=('rust' 'cargo' 'gcc-libs')
+source=("git+https://gitlab.com/thacoon/cpass.git?ref=v$pkgver")
sha256sums=('SKIP')
build() {
@@ -20,3 +19,4 @@ package() {
cd $srcdir/$pkgname
install -D -m755 target/release/$pkgname $pkgdir/usr/bin/$pkgname
}
+