summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornroi2019-08-18 19:39:39 +0200
committernroi2019-08-18 19:39:39 +0200
commit5eafb9afd15ce31893195ca229d2d2b4910f30ea (patch)
tree5281c9e27aa1a51031cc3786d5585d42a515d91f
parentde4dcda5d4ea5df9d6dd3097fcb0c77547cd032e (diff)
downloadaur-5eafb9afd15ce31893195ca229d2d2b4910f30ea.tar.gz
Various fixes required by Elixir 1.9
See also: https://github.com/nroi/cpcache/issues/21
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--cpcache.install5
-rw-r--r--cpcache.service3
4 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1902e913f8ef..d3f90d2f2e0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,8 @@ pkgbase = cpcache-git
source = cpcache.service
sha256sums = SKIP
sha256sums = 0098e749b19617c0f7d619d47a3bc3015bab62e9ad0916087502daff672fb309
- sha256sums = 3ca1bcfb52153bfee7b316174b02cb51e2468bbdc69a41821b96804678ab4d69
- sha256sums = a5d891b7d5cd282a3e7db445d8bbe14b230af7cb1a1e9536130e2f0e514d69bd
+ sha256sums = 6389ceb6fbebfc56ec41e86221d572d65813504a550b1e400f7ab375c3e0ecb5
+ sha256sums = 7f9ac6a73156119d1f1c7125dd5ce6ef8e5fdaa1a55f486d17462b7d3af0f812
pkgname = cpcache-git
diff --git a/PKGBUILD b/PKGBUILD
index aa9f2a8d70ab..ac18b3effd54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ source=('git+https://github.com/nroi/cpcache.git#tag=0.1.0'
)
sha256sums=('SKIP'
'0098e749b19617c0f7d619d47a3bc3015bab62e9ad0916087502daff672fb309'
- '3ca1bcfb52153bfee7b316174b02cb51e2468bbdc69a41821b96804678ab4d69'
- 'a5d891b7d5cd282a3e7db445d8bbe14b230af7cb1a1e9536130e2f0e514d69bd'
+ '1fd14ab29e17b07eaeb9634b160380feeb67fef6c15710df2e88e488c69ee0e5'
+ '7f9ac6a73156119d1f1c7125dd5ce6ef8e5fdaa1a55f486d17462b7d3af0f812'
)
pkgver() {
@@ -31,12 +31,12 @@ package() {
HOME="$TMP" /usr/bin/mix local.hex --force
HOME="$TMP" /usr/bin/mix local.rebar --force
HOME="$TMP" /usr/bin/mix deps.get
- HOME="$TMP" MIX_ENV=prod /usr/bin/mix release --env=prod
+ HOME="$TMP" MIX_ENV=prod /usr/bin/mix release
mkdir -p "${pkgdir}/usr/share/${pkgname%-git}"
mkdir -p "${pkgdir}/var/lib/${pkgname%-git}"
mkdir -p "${pkgdir}/etc/cpcache"
cd "${pkgdir}/usr/share/${pkgname%-git}"
- tar xf "${srcdir}/${pkgname%-git}/cpcache/_build/prod/rel/${pkgname%-git}/releases/0.1.0/${pkgname%-git}.tar.gz"
+ mv "${srcdir}/${pkgname%-git}/cpcache/_build/prod/rel/${pkgname%-git}"/* .
ln -s "/var/lib/${pkgname%-git}" var
install -Dm644 "${srcdir}/cpcache.service" "${pkgdir}/usr/lib/systemd/system/cpcache.service"
install -Dm644 "${srcdir}/sysuser.conf" "${pkgdir}/usr/lib/sysusers.d/cpcache.conf"
diff --git a/cpcache.install b/cpcache.install
index 01d77d5f167e..f6b8b7db1a31 100644
--- a/cpcache.install
+++ b/cpcache.install
@@ -1,11 +1,14 @@
post_install() {
systemd-sysusers cpcache.conf
- mkdir -p /var/cache/cpcache/pkg/{community,community-staging,community-testing,core,extra,gnome-unstable,kde-unstable,multilib,multilib-testing,staging,testing}/os/x86_64
+ mkdir -p /var/cache/cpcache/pkg/{community,community-staging,community-testing,core,extra,gnome-unstable,kde-unstable,multilib,mu ltilib-testing,staging,testing}/os/x86_64
mkdir -p /var/cache/cpcache/state
chown -R cpcache:cpcache "/var/cache/cpcache"
+ chown -R cpcache:cpcache "/usr/share/cpcache"
chown cpcache:cpcache "/var/lib/cpcache"
}
post_upgrade() {
systemd-sysusers cpcache.conf
+ chown -R cpcache:cpcache "/var/cache/cpcache"
+ chown -R cpcache:cpcache "/usr/share/cpcache"
}
diff --git a/cpcache.service b/cpcache.service
index 72fb017cfe6c..227e00716e3e 100644
--- a/cpcache.service
+++ b/cpcache.service
@@ -9,8 +9,7 @@ TimeoutSec=90
SuccessExitStatus=143
User=cpcache
Group=cpcache
-Environment="ELIXIR_ERL_OPTIONS=-sname cpcache"
-ExecStart=/usr/share/cpcache/bin/cpcache foreground
+ExecStart=/usr/share/cpcache/bin/cpcache start
ExecStop=/usr/share/cpcache/bin/cpcache stop
[Install]