summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshar2020-04-04 06:45:08 +0000
committerAshar2020-04-04 06:45:08 +0000
commit2953888e0f0b1f8894bf94196fdd6317fb00ad03 (patch)
tree4b9d32b149922739887ab79cf83091aa145bfb5e
downloadaur-2953888e0f0b1f8894bf94196fdd6317fb00ad03.tar.gz
Add sources
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf7d5af5142
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cpeditor
+ pkgdesc = IDE desgined for Competitive Programming
+ pkgver = 6.2.2
+ pkgrel = 1
+ url = https://github.com/cpeditor/cpeditor
+ arch = x86_64
+ license = GLP3
+ makedepends = cmake
+ makedepends = git
+ makedepends = gcc
+ depends = qt5-base
+ conflicts = cpeditor-git
+ source = https://github.com/cpeditor/cpeditor/releases/download/6.2.2/cpeditor-full-source-6.2.2.tar.gz
+ md5sums = SKIP
+
+pkgname = cpeditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06709ee74921
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ashar Khan <ashar786khan at gmail.com>
+
+pkgname=cpeditor
+pkgver=6.2.2
+_pkgdir=cpeditor-full-source-$pkgver
+pkgrel=1
+pkgdesc='IDE desgined for Competitive Programming'
+arch=('x86_64')
+url='https://github.com/cpeditor/cpeditor'
+license=('GLP3')
+depends=('qt5-base')
+makedepends=("cmake" "git" "gcc")
+conflicts=("cpeditor-git")
+source=("https://github.com/cpeditor/$pkgname/releases/download/$pkgver/cpeditor-full-source-$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd $_pkgdir
+ cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=g++
+ cmake --build build
+}
+
+package() {
+ cd $_pkgdir/build
+ make DESTDIR="$pkgdir" install
+}
+
+
+