summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoder31012020-07-21 12:54:35 +0000
committercoder31012020-07-21 12:54:35 +0000
commit4b2f5d4be031d1a28838a3bd2bf67fa11a61b53d (patch)
tree3269e7b18b05932bba01ec9fb62bdcea727fbba3
parent09d6cd437d9f6e591dd88ecc59c584cc6d5a7b8d (diff)
downloadaur-4b2f5d4be031d1a28838a3bd2bf67fa11a61b53d.tar.gz
Update from CI: 6.5.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86d4c04f3ad7..c2d95c380a82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
pkgbase = cpeditor
pkgdesc = The editor for competitive programming
- pkgver = 6.4.7
+ pkgver = 6.5.3
pkgrel = 1
url = https://github.com/cpeditor/cpeditor
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = git
- makedepends = gcc
makedepends = python3
depends = qt5-base
+ optdepends = cf-tool: submit to Codeforces support
+ optdepends = clang: C++ format and language server support
+ optdepends = jdk-openjdk: compile Java support
+ optdepends = jre-openjdk: execute Java support
+ optdepends = python: execute Python support
+ optdepends = xterm: detached run support
conflicts = cpeditor-git
- source = https://github.com/cpeditor/cpeditor/releases/download/6.4.7/cpeditor-full-source-6.4.7.tar.gz
- md5sums = SKIP
+ source = https://github.com/cpeditor/cpeditor/releases/download/6.5.3/cpeditor-6.5.3-full-source.tar.gz
+ sha256sums = 43185c017539bc0335b4c6db472690a2f208a932e5d68c8069a3c61f95fee527
pkgname = cpeditor
+
diff --git a/PKGBUILD b/PKGBUILD
index 8316a680c6d7..bb970f336967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,34 @@
# Maintainer: Ashar Khan <ashar786khan at gmail.com>
pkgname=cpeditor
-pkgver=6.4.7
-_pkgdir=cpeditor-full-source-$pkgver
+pkgver=6.5.3
+_pkgdir=cpeditor-$pkgver-full-source
pkgrel=1
pkgdesc='The editor for competitive programming'
arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
license=('GPL3')
depends=('qt5-base')
-makedepends=("cmake" "git" "gcc" "python3")
+makedepends=("cmake" "git" "python3")
+optdepends=(
+ 'cf-tool: submit to Codeforces support'
+ 'clang: C++ format and language server support'
+ 'jdk-openjdk: compile Java support'
+ 'jre-openjdk: execute Java support'
+ 'python: execute Python support'
+ 'xterm: detached run support'
+)
conflicts=("cpeditor-git")
-source=("https://github.com/cpeditor/$pkgname/releases/download/$pkgver/cpeditor-full-source-$pkgver.tar.gz")
-md5sums=('SKIP')
+source=("https://github.com/cpeditor/$pkgname/releases/download/$pkgver/cpeditor-$pkgver-full-source.tar.gz")
+sha256sums=('43185c017539bc0335b4c6db472690a2f208a932e5d68c8069a3c61f95fee527')
build() {
- cd $_pkgdir
- cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_CXX_COMPILER=g++
+ cd "$_pkgdir"
+ cmake -H. -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
cmake --build build -j$(nproc)
}
package() {
- cd $_pkgdir/build
+ cd "$_pkgdir/build"
make DESTDIR="$pkgdir" install
}