summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoder31012023-07-23 04:54:44 +0000
committercoder31012023-07-23 04:54:44 +0000
commita425b26e7f3b784e0c2c9de3715803d21e5671c3 (patch)
tree33080b5aef397fecde2cc2ba3e59ce12993ffb9e
parent7c26e3cfee9a2fbec8ec35f8582a11a47d1c3810 (diff)
downloadaur-a425b26e7f3b784e0c2c9de3715803d21e5671c3.tar.gz
Update from CI: 6.11.1.r15.g79bcba11
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c10d8021298d..9107a8ef6d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpeditor-git
pkgdesc = The editor for competitive programming
- pkgver = 6.11.1.r14.g5ef969df
+ pkgver = 6.11.1.r15.g79bcba11
pkgrel = 1
url = https://github.com/cpeditor/cpeditor
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = cpeditor-git
makedepends = python3
makedepends = qt5-tools
depends = qt5-base
+ depends = syntax-highlighting
depends = hicolor-icon-theme
optdepends = cf-tool: submit to Codeforces
optdepends = clang: C++ format and language server
@@ -21,7 +22,6 @@ pkgbase = cpeditor-git
provides = cpeditor
conflicts = cpeditor
source = git+https://github.com/cpeditor/cpeditor.git
- source = git+https://github.com/cpeditor/QCodeEditor.git
source = git+https://github.com/cpeditor/QtFindReplaceDialog.git
source = git+https://github.com/cpeditor/lsp-cpp.git
source = git+https://github.com/itay-grudev/singleapplication.git
@@ -33,6 +33,5 @@ pkgbase = cpeditor-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = cpeditor-git
diff --git a/PKGBUILD b/PKGBUILD
index 793911844dcd..cf50e08665b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=cpeditor-git
_pkgname=cpeditor
-pkgver=6.11.1.r14.g5ef969df
+pkgver=6.11.1.r15.g79bcba11
pkgrel=1
pkgdesc='The editor for competitive programming'
arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
license=('GPL3')
-depends=('qt5-base' 'hicolor-icon-theme')
+depends=('qt5-base' 'syntax-highlighting' 'hicolor-icon-theme')
makedepends=(
"cmake"
"git"
@@ -28,14 +28,13 @@ provides=('cpeditor')
conflicts=("cpeditor")
source=('git+https://github.com/cpeditor/cpeditor.git'
- 'git+https://github.com/cpeditor/QCodeEditor.git'
'git+https://github.com/cpeditor/QtFindReplaceDialog.git'
'git+https://github.com/cpeditor/lsp-cpp.git'
'git+https://github.com/itay-grudev/singleapplication.git'
'git+https://github.com/MikeMirzayanov/testlib.git'
'git+https://github.com/cpeditor/qhttp.git')
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -46,7 +45,6 @@ prepare() {
cd "$_pkgname"
git submodule init
- git config submodule.third_party/QCodeEditor.url "$srcdir/QCodeEditor"
git config submodule.third_party/QtFindReplaceDialog.url "$srcdir/QtFindReplaceDialog"
git config submodule.third_party/lsp-cpp.url "$srcdir/lsp-cpp"
git config submodule.third_party/singleapplication.url "$srcdir/singleapplication"