summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-03-21 16:51:06 +0800
committerChocobo12019-03-21 16:59:35 +0800
commitc5a820d22542ee4cdec449313a11eb9fac43f243 (patch)
treedbbe50e591746655f24eef34a72484b6719af8f1
downloadaur-c5a820d22542ee4cdec449313a11eb9fac43f243.tar.gz
newpkg: cpio-git 2.12.r15.g068f5db-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1321eb54fe20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cpio-git
+ pkgdesc = Utility that copy files into or out of a cpio or tar archive
+ pkgver = 2.12.r15.g068f5db
+ pkgrel = 1
+ url = https://www.gnu.org/software/cpio/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = cpio
+ conflicts = cpio
+ source = git+https://git.savannah.gnu.org/git/cpio.git
+ sha256sums = SKIP
+
+pkgname = cpio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fe2767d0a2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=cpio-git
+pkgver=2.12.r15.g068f5db
+pkgrel=1
+pkgdesc="Utility that copy files into or out of a cpio or tar archive"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/cpio/"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('cpio')
+conflicts=('cpio')
+source=("git+https://git.savannah.gnu.org/git/cpio.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "cpio"
+
+ git describe --long --tags | sed 's/^release_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+}
+
+build() {
+ cd "cpio"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "cpio"
+
+ make check
+}
+
+package() {
+ cd "cpio"
+
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "$pkgdir/usr/libexec"
+ rm -rf "$pkgdir/usr/share/man/man8"
+}