summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122018-04-06 18:17:20 +0200
committerwillemw122018-04-06 18:18:35 +0200
commit4a6335e831b2ca9936ba246dd2b2edae0e8968b1 (patch)
tree51b9833680f206929f100181ae33c01fab1d9a67
downloadaur-4a6335e831b2ca9936ba246dd2b2edae0e8968b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..309fd15f7aea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Apr 6 16:17:06 UTC 2018
+pkgbase = cpod-git
+ pkgdesc = A simple, beautiful podcast app
+ pkgver = 1.22.6.r0.ge4362cb
+ pkgrel = 1
+ url = https://github.com/z-------------/cumulonimbus
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = gulp
+ makedepends = python2
+ makedepends = yarn
+ depends = gconf
+ depends = gtk-update-icon-cache
+ provides = cpod
+ conflicts = cpod
+ replaces = cumulonimbus
+ source = cpod-git::git+https://github.com/z-------------/cumulonimbus.git
+ sha256sums = SKIP
+
+pkgname = cpod-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..414af8898623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=cpod
+pkgname=$_pkgname-git
+pkgver=1.22.6.r0.ge4362cb
+pkgrel=1
+pkgdesc="A simple, beautiful podcast app"
+arch=('x86_64')
+url="https://github.com/z-------------/cumulonimbus"
+license=('Apache')
+depends=('gconf' 'gtk-update-icon-cache')
+makedepends=('git' 'gulp' 'python2' 'yarn')
+provides=($_pkgname)
+conflicts=($_pkgname)
+replaces=('cumulonimbus')
+source=($pkgname::git+https://github.com/z-------------/cumulonimbus.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ yarn
+ gulp
+}
+
+package() {
+ cd $pkgname
+ rm -rf dist
+ yarn dist --linux deb # --x64
+
+ cd dist
+ bsdtar xf CPod_*.deb data.tar.xz
+ bsdtar xf data.tar.xz --directory "$pkgdir"
+
+ install -dm755 "$pkgdir/usr/bin"
+ ln -sf /opt/CPod/cumulonimbus "$pkgdir/usr/bin/cpod"
+}
+