summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Wiesinger2024-03-28 01:39:52 +0000
committerManuel Wiesinger2024-03-28 01:39:52 +0000
commitaa8032a0eff6389bcb3cb998be52f9f1e420fb75 (patch)
tree2c8add5faec5b7f9d0f1421cd341c2e5af2c7a42
parent5d2c043a0dfce3be5c7b4dab7bf9e3f64ad40170 (diff)
downloadaur-aa8032a0eff6389bcb3cb998be52f9f1e420fb75.tar.gz
minor cosmetics, intentionally no new .SRCINFO
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f0aa9b6000a..7caa85cd007b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Manuel Wiesinger <m {you know what belongs here} mmap {and here} at>
-pkgname=cpotree
_srcname=CPotree
+pkgname=cpotree
pkgver=1.0
pkgrel=2
pkgdesc="Potree Utilities"
@@ -9,16 +9,17 @@ arch=('x86_64')
url="https://github.com/potree/CPotree"
license=('BSD-2-Clause')
depends=('gcc-libs' 'glibc' 'brotli' 'laszip' 'onetbb')
-conflicts=('cpotree-git')
+conflicts=("${pkgname}-git")
source=("$pkgname-$pkgver.tar.gz::https://github.com/potree/${_srcname}/archive/refs/tags/${pkgver}.tar.gz"
"https://github.com/potree/${_srcname}/blob/master/LICENSE")
b2sums=('2ed8be18c353bee5d52a371af9ca59961446087ee3b7883e6416f26b1f81bd6d0f445f8fb8bf6534cc6d295856fb326ed4ff60619ced8d3a063aa12c057f95d1'
'0dc2dc0f814a5ffe7eabbec6029b740fe9a53e37b53b336b911c3a32fd96050a299c1ba7e6e61e389a9a075050162ea462c72b9dbb84fca03a7a898aa35bf67a')
build() {
+ cd "$srcdir/$_srcname-$pkgver/src"
+
CXX="${CXX:=g++}"
- cd "$srcdir/$_srcname-$pkgver/src"
$CXX -std=c++20 -I../include/ -I../modules -idirafter../libs executable_extract_area.cpp ../modules/unsuck/unsuck_platform_specific.cpp -lbrotlidec -llaszip -ltbb -o extract_area
$CXX -std=c++20 -I../include/ -I../modules -idirafter../libs executable_extract_profile.cpp ../modules/unsuck/unsuck_platform_specific.cpp -lbrotlidec -llaszip -ltbb -o extract_profile
}
@@ -27,6 +28,7 @@ package() {
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$srcdir/$_srcname-$pkgver/src"
+
install -Dm755 extract_area "$pkgdir"/usr/bin/extract_area
install -Dm755 extract_profile "$pkgdir"/usr/bin/extract_profile
}