summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2015-03-16 16:06:38 +0100
committerCedric Girard2015-03-16 16:06:38 +0100
commit5355d5d0b7b95ee7b7e0ceaeec450f3b14a20af9 (patch)
tree6ef3cf903b4e3807cf153d5ae240f53a6ed1c477
downloadaur-5355d5d0b7b95ee7b7e0ceaeec450f3b14a20af9.tar.gz
cppAlsaVolume PKGBUILD (first version)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06241568345e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cpp-alsa-volume
+ pkgdesc = Tray Alsa Volume Changer written using gtkmm
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/Vitozz/cppAlsaVolume
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = gtkmm
+ makedepends = glibmm
+ makedepends = alsa-lib
+ makedepends = cmake
+ depends = gtkmm
+ depends = glibmm
+ depends = alsa-lib
+ source = https://github.com/Vitozz/cppAlsaVolume/archive/v0.2.6.tar.gz
+ source = https://github.com/Vitozz/cppAlsaVolume/commit/5ad2b3e23fecfdfdd9e87b9cd70b5c02fb31da39.patch
+ md5sums = 51c9bec739b1a0174881dc6890096e58
+ md5sums = 1066cf5d687eb82a1e3c76bbc8abe02b
+
+pkgname = cpp-alsa-volume
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b58058f51b6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+pkgname=cpp-alsa-volume
+_upstreamname=cppAlsaVolume
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Tray Alsa Volume Changer written using gtkmm"
+arch=('x86_64' 'i686')
+url="https://github.com/Vitozz/cppAlsaVolume"
+license=('GPL2')
+makedepends=('gtkmm' 'glibmm' 'alsa-lib' 'cmake')
+depends=('gtkmm' 'glibmm' 'alsa-lib')
+source=("https://github.com/Vitozz/cppAlsaVolume/archive/v${pkgver}.tar.gz"
+ "https://github.com/Vitozz/cppAlsaVolume/commit/5ad2b3e23fecfdfdd9e87b9cd70b5c02fb31da39.patch")
+
+prepare() {
+ cd "$_upstreamname-$pkgver"
+ patch -p1 -i "$srcdir/5ad2b3e23fecfdfdd9e87b9cd70b5c02fb31da39.patch"
+}
+
+build() {
+ cd "$_upstreamname-$pkgver"
+ cmake -DUSE_GTK3=OFF -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_upstreamname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+md5sums=('51c9bec739b1a0174881dc6890096e58'
+ '1066cf5d687eb82a1e3c76bbc8abe02b')