summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Dollé2021-03-21 15:56:58 +0100
committerGuillaume Dollé2021-03-21 15:56:58 +0100
commit180a27e64f0d9442c9c0fafbc3b7c7c4a53aac76 (patch)
tree25724c85b61947a9c0a99acf33b512b0bbd10b6a
parent9d13a92b752782dd7fc5135a59efd07b753fa333 (diff)
downloadaur-180a27e64f0d9442c9c0fafbc3b7c7c4a53aac76.tar.gz
Rename to cpp-ghc-filesystem
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5591c636a862..c1b6929d36c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-pkgbase = filesystem-cpp
- pkgdesc = C++ header-only single-file std filesystem compatible helper library, ghc
+pkgbase = cpp-ghc-filesystem
+ pkgdesc = ghc C++ header-only single-file std filesystem compatible helper library
pkgver = 1.5.2
pkgrel = 1
url = https://github.com/gulrak/filesystem
@@ -7,8 +7,8 @@ pkgbase = filesystem-cpp
arch = x86_64
license = MIT
depends = gcc
- source = filesystem-cpp-1.5.2.tar.gz::https://github.com/gulrak/filesystem/archive/v1.5.2.tar.gz
+ source = cpp-ghc-filesystem-1.5.2.tar.gz::https://github.com/gulrak/filesystem/archive/v1.5.2.tar.gz
md5sums = 2104e4da3a9be52f496b51fa3248df8d
-pkgname = filesystem-cpp
+pkgname = cpp-ghc-filesystem
diff --git a/PKGBUILD b/PKGBUILD
index 45397f1b062e..1abfa368ec71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Guillaume Dolle <dev at gdolle.com>
-pkgname=filesystem-cpp
+pkgname=cpp-ghc-filesystem
pkgver=1.5.2
pkgrel=1
-pkgdesc="C++ header-only single-file std filesystem compatible helper library, ghc"
+pkgdesc="ghc C++ header-only single-file std filesystem compatible helper library"
arch=('i686' 'x86_64')
url="https://github.com/gulrak/filesystem"
license=('MIT')
@@ -11,25 +11,24 @@ source=(${pkgname}-${pkgver}.tar.gz::https://github.com/gulrak/filesystem/archiv
md5sums=('2104e4da3a9be52f496b51fa3248df8d')
prepare(){
- cd ${pkgname//-cpp}-${pkgver}
+ cd ${pkgname/cpp-ghc-/}-${pkgver}
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
-B build
}
build() {
- cd ${pkgname//-cpp}-${pkgver}
+ cd ${pkgname/cpp-ghc-/}-${pkgver}
cmake --build build
}
check() {
- cd ${pkgname//-cpp}-${pkgver}/build
+ cd ${pkgname/cpp-ghc-/}-${pkgver}/build
ctest
}
package() {
- cd ${pkgname//-cpp}-${pkgver}
+ cd ${pkgname/cpp-ghc-/}-${pkgver}
cmake --install build
}
-