summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo J.A. de Vries2016-05-21 11:17:39 +0200
committerTheo J.A. de Vries2016-05-21 11:17:39 +0200
commita5d238970379dc2cdbb55cbca405c0d51242eec1 (patch)
tree075c60bec074acfbaa0ff0564c2c64f9ea5536cf
parente15211bf5b909285784dd5b2de48e53bbb4ae9d1 (diff)
downloadaur-a5d238970379dc2cdbb55cbca405c0d51242eec1.tar.gz
update to version 0.12
-rw-r--r--.SRCINFO9
-rw-r--r--OPENSSL_NO_SSL3.patch25
-rw-r--r--PKGBUILD16
3 files changed, 43 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff1d3f7ce60f..2ce98b4b3fec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = cpp-netlib
pkgdesc = A library that provides application layer protocol support using modern C++ techniques
- pkgver = 0.11.2
+ pkgver = 0.12.0
pkgrel = 1
url = http://cpp-netlib.github.com/
arch = i686
arch = x86_64
license = custom
makedepends = cmake>=2.8.10
- depends = boost>=1.54.0
optdepends = openssl: for https
- source = http://downloads.cpp-netlib.org/0.11.2/cpp-netlib-0.11.2-final.tar.gz
- sha256sums = 71953379c5a6fab618cbda9ac6639d87b35cab0600a4450a7392bc08c930f2b1
+ source = http://downloads.cpp-netlib.org/0.12.0/cpp-netlib-0.12.0-final.tar.gz
+ source = OPENSSL_NO_SSL3.patch
+ sha256sums = a0a4a5cbb57742464b04268c25b80cc1fc91de8039f7710884bf8d3c060bd711
+ sha256sums = e7b4b7ecdafb51211d9be65fd179e8cd7cea71480aaeb4f30f11d5c8fc251f03
pkgname = cpp-netlib
diff --git a/OPENSSL_NO_SSL3.patch b/OPENSSL_NO_SSL3.patch
new file mode 100644
index 000000000000..58a60e2cf350
--- /dev/null
+++ b/OPENSSL_NO_SSL3.patch
@@ -0,0 +1,25 @@
+--- deps/asio/asio/include/asio/ssl/impl/context.ipp
++++ deps/asio/asio/include/asio/ssl/impl/context.ipp
+@@ -89,6 +89,14 @@ context::context(context::method m)
+ handle_ = ::SSL_CTX_new(::SSLv2_server_method());
+ break;
+ #endif // defined(OPENSSL_NO_SSL2)
++#if defined(OPENSSL_NO_SSL3)
++ case context::sslv3:
++ case context::sslv3_client:
++ case context::sslv3_server:
++ asio::detail::throw_error(
++ asio::error::invalid_argument, "context");
++ break;
++#else // defined(OPENSSL_NO_SSL3)
+ case context::sslv3:
+ handle_ = ::SSL_CTX_new(::SSLv3_method());
+ break;
+@@ -98,6 +106,7 @@ context::context(context::method m)
+ case context::sslv3_server:
+ handle_ = ::SSL_CTX_new(::SSLv3_server_method());
+ break;
++#endif // defined(OPENSSL_NO_SSL3)
+ case context::tlsv1:
+ handle_ = ::SSL_CTX_new(::TLSv1_method());
+ break; \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d0b9f7cdfe51..cb5940dee66b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,27 +9,37 @@ _basedir=/usr
_boost=boost${_ext}
pkgname=${_pkgname}${_ext}
-pkgver=0.11.2
+pkgver=0.12.0
pkgrel=1
pkgdesc="A library that provides application layer protocol support using modern C++ techniques"
arch=('i686' 'x86_64')
url="http://cpp-netlib.github.com/"
license=('custom')
-depends=("boost${_ext}>=1.54.0")
+depends=()
optdepends=('openssl: for https')
makedepends=("cmake>=2.8.10")
#options=(staticlibs)
source=(
http://downloads.cpp-netlib.org/$pkgver/$_pkgname-$pkgver-final.tar.gz
+ OPENSSL_NO_SSL3.patch
)
sha256sums=(
- '71953379c5a6fab618cbda9ac6639d87b35cab0600a4450a7392bc08c930f2b1'
+ 'a0a4a5cbb57742464b04268c25b80cc1fc91de8039f7710884bf8d3c060bd711'
+ 'e7b4b7ecdafb51211d9be65fd179e8cd7cea71480aaeb4f30f11d5c8fc251f03'
)
+prepare() {
+ cd "$pkgname-$pkgver-final"
+ patch -Np0 -i "$srcdir/OPENSSL_NO_SSL3.patch"
+}
+
build() {
install -d $srcdir/build
cd $srcdir/build
+ # use asio from system
+# sed -i -e "s|include_directories(deps/asio/asio/include)||g" $srcdir/$_pkgname-$pkgver-final/CMakeLists.txt
cmake -DBOOST_ROOT=$_basedir -DCPP-NETLIB_BUILD_TESTS=OFF -DCPP-NETLIB_BUILD_EXAMPLES=OFF -DCPP-NETLIB_BUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}${_basedir} ../"$_pkgname-$pkgver-final"
+# cmake -DBOOST_ROOT=$_basedir -DCPP-NETLIB_BUILD_TESTS=ON -DCPP-NETLIB_BUILD_EXAMPLES=ON -DCPP-NETLIB_BUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}${_basedir} ../"$_pkgname-$pkgver-final"
make
# make test
}