summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJitang Zheng2016-08-15 12:31:30 -0700
committerJitang Zheng2016-08-15 12:31:30 -0700
commitc45bf4a8c85a7b03c4d7e0c5600705114cc6d2c0 (patch)
tree84474955edc8f5f1ece08879216a68ae81cad272
downloadaur-cpp-netlib-uri-git.tar.gz
Bump version 60c0da3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..965e2cc71ec2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cpp-netlib-uri-git
+ pkgdesc = cpp-netlib URI
+ pkgver = 60c0da3
+ pkgrel = 1
+ url = https://github.com/cpp-netlib/uri
+ arch = i686
+ arch = x86_64
+ license = BOOST
+ makedepends = git
+ makedepends = cmake
+ makedepends = clang
+ provides = cpp-netlib-uri
+ conflicts = cpp-netlib-uri
+ replaces = cpp-netlib-uri
+ source = git+https://github.com/cpp-netlib/uri.git
+ md5sums = SKIP
+
+pkgname = cpp-netlib-uri-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74cf5731a1cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jitang Zheng <jitang.zheng@gmail.com>
+
+pkgname=cpp-netlib-uri-git
+pkgver=60c0da3
+pkgrel=1
+pkgdesc='cpp-netlib URI'
+arch=(i686 x86_64)
+url='https://github.com/cpp-netlib/uri'
+license=(BOOST)
+conflicts=(cpp-netlib-uri)
+provides=(cpp-netlib-uri)
+replaces=(cpp-netlib-uri)
+depends=()
+makedepends=(git cmake clang)
+source=(git+https://github.com/cpp-netlib/uri.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd uri
+ git rev-parse --short HEAD
+}
+
+prepare() {
+ [ -d uri-build ] && rm -r uri-build
+ cd uri
+ git submodule init
+ git submodule update
+}
+
+build() {
+ mkdir uri-build
+ cd uri-build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
+ -DUri_BUILD_TESTS=OFF \
+ -DUri_BUILD_DOCS=OFF \
+ -DUri_DISABLE_LIBCXX=ON \
+ -DCMAKE_INSTALL_PREFIX=$pkgdir/usr ../uri
+ make
+}
+
+check() {
+ cd uri-build
+ #make check
+}
+
+package() {
+ cd uri-build
+ make install
+
+ #mkdir ${pkgdir}/usr/include/network
+ mv ${pkgdir}/usr/include/include/network ${pkgdir}/usr/include
+ rmdir ${pkgdir}/usr/include/include
+}