summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFijxu2024-01-13 00:29:55 -0300
committerFijxu2024-01-13 00:29:55 -0300
commit97946398988e5a925d54d61366fd5c1ad3040b51 (patch)
tree987f6a7dba0b870f2edbce9cb8df668284eafb91
parenta04a869eea87bbab1672d6378d1e96293acb24c6 (diff)
downloadaur-97946398988e5a925d54d61366fd5c1ad3040b51.tar.gz
Update package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 138bae735135..a68f8f808b40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cpp2il-git
pkgdesc = Work-in-progress tool to reverse unity's IL2CPP toolchain. (git version)
- pkgver = 2022.0.7.r15.g4c5326d
+ pkgver = 2022.0.7.r17.g20ccab2
pkgrel = 1
url = https://github.com/SamboyCoding/Cpp2IL
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 56a4a1ae0e74..4038af398028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Fijxu <fijxu[at]zzls[dot]xyz>
+# Maintainer: Fijxu <fijxu at nadeko dot net>
pkgname=cpp2il-git
_pkgname=cpp2il
-pkgver=2022.0.7.r15.g4c5326d
+pkgver=2022.0.7.r17.g20ccab2
pkgrel=1
pkgdesc="Work-in-progress tool to reverse unity's IL2CPP toolchain. (git version)"
arch=('x86_64' 'aarch64')
@@ -20,9 +20,8 @@ pkgver() {
build() {
cd $_pkgname/Cpp2IL
-
dotnet restore
- dotnet build Cpp2IL.csproj -c Release -r linux-x64 -f net6.0 --no-self-contained
+ dotnet build Cpp2IL.csproj -c Release -r linux-x64 --no-self-contained
}
package() {
@@ -39,6 +38,5 @@ EOF
install -dm 755 "$pkgdir/usr/share/$_pkgname"
install -Dm 644 -t "$pkgdir/usr/share/doc/$_pkgname/" *.md
- cp -a --no-preserve=ownership ./Cpp2IL/bin/Release/net6.0/linux-x64/* \
- "$pkgdir/usr/share/$_pkgname/"
+ cp -a --no-preserve=ownership ./Cpp2IL/bin/Release/net6.0/linux-x64/* "$pkgdir/usr/share/$_pkgname/"
}