summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-01-25 20:27:54 -0500
committeracxz2020-01-25 20:27:54 -0500
commita4010ee7626da34598a106779a8544516ddf321f (patch)
tree1afa0f887dea51404b976b252b003061b14d6ef4
downloadaur-cppadcodegen-git.tar.gz
create cppadcodegen-git package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a80655d3c88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cppadcodegen-git
+ pkgdesc = A C++ Algorithmic Differentiation Package
+ pkgver = r928.38d4f3b
+ pkgrel = 1
+ url = https://github.com/joaoleal/CppADCodeGen
+ arch = any
+ license = GPL3
+ license = EPL1
+ makedepends = cmake
+ depends = cppad
+ optdepends = eigen: required when DAE differentiation index reduction is used,
+ optdepends = valgrind: memcheck test
+ optdepends = clang: only required for JIT compilation
+ optdepends = llvm: only required for JIT compilation
+ provides = cppadcodegen
+ conflicts = cppadcodegen
+ source = git+https://github.com/joaoleal/CppADCodeGen.git
+ sha256sums = SKIP
+
+pkgname = cppadcodegen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e9dd76a6c65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: acxz <akashpatel200 at yahoo dot com>
+
+pkgname=cppadcodegen-git
+pkgver=r928.38d4f3b
+pkgrel=1
+pkgdesc="A C++ Algorithmic Differentiation Package"
+url="https://github.com/joaoleal/CppADCodeGen"
+arch=('any')
+license=('GPL3' 'EPL1')
+depends=('cppad')
+optdepends=('eigen: required when DAE differentiation index reduction is used',
+ 'valgrind: memcheck test'
+ 'clang: only required for JIT compilation'
+ 'llvm: only required for JIT compilation')
+makedepends=('cmake')
+provides=('cppadcodegen')
+conflicts=('cppadcodegen')
+_pkgname=CppADCodeGen
+source=("git+https://github.com/joaoleal/CppADCodeGen.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "$srcdir/${_pkgname}/build"
+ cd "$_pkgname/build"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}